Missing i386 version of libnss-sss

Bug #1904990 reported by Kees Bakker
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sssd (Ubuntu)
Fix Released
Undecided
Sergio Durigan Junior

Bug Description

In Ubuntu 20.04 there is no i386 support of libnss-sss anymore. Now certain (older) programs don't work anymore in an environment with SSSD.

I'd like to request to bring the i386 support back to life.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

programs such as?

Revision history for this message
Kees Bakker (keestux) wrote :

Commercial tools such as the Green Hills compilers. Of course there are updates, but sometimes it is not possible, or allowed to upgrade due to safety restrictions.

Revision history for this message
Kees Bakker (keestux) wrote :

What would it take to build the deb myself? I know how to build packages, but not how to build a i386 deb on my amd64 machine.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

nothing to be done here, you just need to request for the package to be included in the i386 seed, see

https://wiki.ubuntu.com/i386
https://discourse.ubuntu.com/t/community-process-for-32-bit-compatibility/12598

Changed in sssd (Ubuntu):
status: New → Invalid
Revision history for this message
Steve Langasek (vorlon) wrote :

Hi Timo,

I'm reopening this bug, because sssd currently has an unreasonable set of build-dependencies for turning on i386 support (including some gnome packages that have a build-dependency loop. Could we drop the build dependency on gdm on i386?

Changed in sssd (Ubuntu):
status: Invalid → Triaged
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

yes, that would be fine, but not on Debian I think

Revision history for this message
Kees Bakker (keestux) wrote :

Hi Timo,

Any news on this?

Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

Hi Steve,

I had a chance to talk to Timo and Andreas and we all agree that it should be OK to drop the B-D on gdbm on i386. Thanks!

Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

I'm going to update the sssd package to reflect what we've discussed.

Changed in sssd (Ubuntu):
assignee: nobody → Sergio Durigan Junior (sergiodj)
Revision history for this message
Kees Bakker (keestux) wrote :

What's the progress on this?

Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

https://launchpad.net/ubuntu/+source/sssd

sssd has been uploaded and migrated to impish-release. This upload brings back i386 support, including libnss-sss. I'm marking this bug as Fix Released.

Changed in sssd (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Mathew Hodson (mhodson) wrote :

sssd (2.4.0-1ubuntu7) impish; urgency=medium

  * d/control: Drop libgdm-dev Build-Depend on i386.

 -- Sergio Durigan Junior <email address hidden> Tue, 11 May 2021 16:22:31 -0400

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers