AppArmor parser error in sssd-common

Bug #1489378 reported by karl forner on 2015-08-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sssd (Ubuntu)
Undecided
Unassigned

Bug Description

apt-add-repository http://ppa.launchpad.net/sssd/updates/ubuntu
apt-get install sssd

Setting up sssd-common (1.12.5-1~trusty1) ...
Installing new version of config file /etc/default/sssd ...
Installing new version of config file /etc/init/sssd.conf ...
Installing new version of config file /etc/apparmor.d/usr.sbin.sssd ...
Warning: found usr.sbin.sssd in /etc/apparmor.d/force-complain, forcing complain mode
AppArmor parser error for /etc/apparmor.d/usr.sbin.sssd in /etc/apparmor.d/usr.sbin.sssd at line 45: syntax error, unexpected TOK_ID, expecting TOK_MODE
sssd start/running

on Ubuntu 14.04.3 LTS, Linux 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:43:14 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

tags: added: trusty
Jochen Hein (jochen-jochen) wrote :

This bug affects wily. I have changed line 45 in /etc/apparmor.d/usr.sbin.sssd from

    /var/lib/sss/pubconf/krb5.include.d/ rwdc,

to

    /var/lib/sss/pubconf/krb5.include.d/ rw,

Now the parse error is gone. Now I see if sssd works as expected.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sssd - 1.13.1-2

---------------
sssd (1.13.1-2) unstable; urgency=medium

  * apparmor: Fix access to krb5.include.d. (LP: #1489378)
  * {krb5-common,proxy}.postinst: Chmod the correct files. (Closes:
    #801537, #801538)

 -- Timo Aaltonen <email address hidden> Tue, 13 Oct 2015 16:55:47 +0300

Changed in sssd (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers