sslscan does not support TLS 1.1 and 1.2

Bug #1372741 reported by Jeffrey Walton
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
sslscan (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

sslscan looks like its abandoned. It's splash screen displays version 1.8.2 with a copyright notice from 2009.

ssl scan does *not* support TLS 1.1 and TLS 1.2.

The attached is a modified version I use to build sslscan. It includes TLS 1.1 and TLS 1.2 support. The source was also modified to detect OpenSSL's config option on no-ssl2 (i.e., preprocessor macro OPENSSL_NO_SSL2).

Tags: patch
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Updated sslscan.c to support TLS 1.1 and TLS 1.2" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Jeffrey Walton (noloader) wrote :

Update sslscan.c that picks up the use of OpenSSL 1.0.1 and higher. If anything lower than 1.0.1 is used, then the TLS 1.1 and 1.2 routines are #define'd out.

Revision history for this message
Jeffrey Walton (noloader) wrote :

Update sslscan.c diff that picks up the use of OpenSSL 1.0.1 and higher. If anything lower than 1.0.1 is used, then the TLS 1.1 and 1.2 routines are #define'd out.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sslscan (Ubuntu):
status: New → Confirmed
Revision history for this message
Adrien Nader (adrien-n) wrote :

Hi,

Current versions of sslscan support these. I think the current ones (2.x) don't rely on openssl's SSL/TLS support anymore in order to be able to support both SSL3 and TLS1.3 and I can confirm the TLS support is working fairly well.

Changed in sslscan (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.