Install of ssl-cert hangs forever if NIS is configured in /etc/group

Bug #58033 reported by Paul Smith on 2006-08-28
2
Affects Status Importance Assigned to Milestone
ssl-cert (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ssl-cert

Ubuntu 6.06.1 (x86 desktop install)

On my Ubuntu system at work I have installed NIS, and added the standard line to the end of /etc/group to include all NIS groups:

  +:::

Just today, I discovered I didn't have an MTA on my box (!) so I tried to install postfix which seems to be the standard MTA for Ubuntu; it wanted to install ssl-cert. When it tried to configure ssl-cert, it hung forever with no CPU, etc. Synaptic just sat there for 15 minutes before I finally killed it by hand. I then tried again with "aptitude install ssl-cert" and had the same issue, then again with dpkg -i /var/cache/apt/archives/ssl-cert_1.0.13_all.deb and again it hung. Sample output:

~$ sudo dpkg -i /var/cache/apt/archives/ssl-cert_1.0.13_all.deb
(Reading database ... 93970 files and directories currently installed.)
Preparing to replace ssl-cert 1.0.13 (using .../ssl-cert_1.0.13_all.deb) ...
Unpacking replacement ssl-cert ...
Setting up ssl-cert (1.0.13) ...
    <HANGS HERE> <I use ^C>
Caught a SIGINT.
Cleaning up.
dpkg: error processing ssl-cert (--install):
 subprocess post-installation script killed by signal (Interrupt)
chgrp: invalid group `ssl-cert'
Errors were encountered while processing:
 ssl-cert
~$ chgrp: invalid group `ssl-cert'

I was stumped for a very long, frustrating time.

Because the last line of the error output seemed to be related to groups, on a whim I removed the "+:::" from the end of my /etc/group file.

Lo and behold, ssl-cert installed without a whimper.

Paul Smith (psmith-gnu) wrote :

Actually I discovered this is really a bug in addgroup. I filed another bug #58038 against the adduser package. Please close this one as a duplicate of that one.

Paul Smith (psmith-gnu) wrote :

The bug was really in adduser. See bug #58038

Changed in ssl-cert:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers