Sync srecord 1.52-1 (universe) from Debian unstable (main).

Bug #442829 reported by Charlie_Smotherman on 2009-10-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
srecord (Ubuntu)
Wishlist
Unassigned

Bug Description

srecord FTBFS
Please sync srecord 1.52-1 (universe) from Debian unstable (main).

According to
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20090909-karmic.html
srecord FTBFS. This sync will correct the FTBFS
Contacting MOTU-Release to see if FFe is needed.

Changelog since current karmic version 1.39-1:

srecord (1.52-1) unstable; urgency=low

  * New upstream release.
  * Remove 01_gcc_4.4_support.diff - merged upstream.
  * Update debian/control:
    - bump Standards-Version from 3.8.2 to 3.8.3 (no changes needed).

 -- Fathi Boudra <email address hidden> Sun, 04 Oct 2009 11:53:54 +0200

srecord (1.50-1) unstable; urgency=low

  * New upstream release.
  * Add patch to fix ftbfs with gcc-4.4. (Closes: #504851)
  * Remove patches:
    - 01_gcc_4.3_support.diff - merged upstream.
    - 02_remove_useless_cstdio.diff - merged upstream.
    - 03_groff_fix.diff - merged upstream.
    - 04_section_mismatch.diff - merged upstream.
  * Bump debian/compat from 6 to 7.
  * Update debian/control:
    - remove cdbs build dependency.
    - add libboost-dev and libgcrypt11-dev build dependencies.
    - bump debhelper version to 7.3.
    - bump Standards-Version from 3.7.3 to 3.8.2 (no changes needed).
  * Convert debian/rules to dh usage.
  * Fix debian/watch file.

 -- Fathi Boudra <email address hidden> Mon, 10 Aug 2009 14:14:39 +0200

Changed in srecord (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
James Westby (james-w) on 2009-10-05
Changed in srecord (Ubuntu):
status: Confirmed → New
Charlie_Smotherman (cjsmo) wrote :
Charlie_Smotherman (cjsmo) wrote :
Changed in srecord (Ubuntu):
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
status: New → In Progress
Nathan Handler (nhandler) wrote :

Marking as Incomplete until the necessary information for a Feature Freeze exception (which is required for this sync) is provided.

Changed in srecord (Ubuntu):
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
status: In Progress → Incomplete
Charlie_Smotherman (cjsmo) wrote :
Charlie_Smotherman (cjsmo) wrote :
Charlie_Smotherman (cjsmo) wrote :

I am unable to perform a diff on the upstream release notes due to upstream shipping said release notes in pdf format. I have attached srecord-1.52.pdf for your inspection.

I really do not have any particular interest in srecord, and I do not use this program. I found this updated package on the Debian BTS and noticed that it would fix a FTBFS in ubuntu.

To be honest I have no idea how to test srecord to make sure it is working correctly. I do not mess with EPROM load files much. Hints on how to test srecord would be greatly appreciated.

Charlie

Changed in srecord (Ubuntu):
status: Incomplete → New
StefanPotyra (sistpoty) wrote :

No rdepends, no other bugs in either Ubuntu or Debian, fixes an FTBFS. +1 from me.

Ack from me too. Approved. Someone who can, please set to confirmed.

StefanPotyra (sistpoty) on 2009-10-06
Changed in srecord (Ubuntu):
status: New → Confirmed
James Westby (james-w) wrote :

[Updating] srecord (1.39-1 [Ubuntu] < 1.52-1 [Debian])
 * Trying to add srecord...
  - <srecord_1.52-1.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <srecord_1.52-1.dsc: downloading from http://ftp.debian.org/debian/>
  - <srecord_1.52.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: srecord [universe] -> srecord_1.39-1 [universe].

Changed in srecord (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers