Comment 1 for bug 1448149

Deadwing (deadwing2005) wrote :

I should note that 14.10 shipped with squid 3.3.8 and squidGuard 1.5-2. 15.04 ships with squid 3.3.8 but squidGuard 1.5-4. The 1.5-4 changelog shows they made some changes to support squid 3.4 and how that was the new base version. No wonder 1.5-4 doesn't work with 3.3.8.

From Launchpad:

squidguard 1.5-4 source package in Ubuntu
Changelog
squidguard (1.5-4) unstable; urgency=medium

  * Fix for working with squid 3.4 and higher. Closes: #772831
  * Update dependency to squid3 (>= 3.4.0) because the new patch
      let squidguard only support newer versions of squid3 and
      don't support squid 2.7 anymore.