Ubuntu

Please provide GNUTLS support in squid

Reported by Paul Boot on 2013-01-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
squid3 (Debian)
Confirmed
Unknown
squid3 (Ubuntu)
Wishlist
Unassigned

Bug Description

Since squid3 does an excellent job in proxying and/or terminating HTTPS traffic it would be nice if the package by default would be compiled with ssl/tls support enabled.

See: https://www.banym.de/linux/build-squid-with-enable-ssl-on-debian or
http://www.d90.us/toolbox/2009/05/26/adding-ssl-support-to-squid-package-on-ubuntu/

This was tested this with Ubuntu 10.04.4 LTS \n \l

Micah Gersten (micahg) wrote :

This is impossible right now for license reasons. Please see the discussion in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=180886 for more information.

Changed in squid3 (Ubuntu):
status: New → Won't Fix

This should then be fixed in this project
https://code.launchpad.net/~yadi/squid/crypto-ng ??

Kind regards,

Paul Boot.

On 8 January 2013 04:14, Micah Gersten <email address hidden>wrote:

> This is impossible right now for license reasons. Please see the
> discussion in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=180886
> for more information.
>
> ** Bug watch added: Debian Bug tracker #180886
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=180886
>
> ** Changed in: squid3 (Ubuntu)
> Status: New => Won't Fix
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1097032
>
> Title:
> Build squid3 with –enable-ssl option by default
>
> Status in “squid3” package in Ubuntu:
> Won't Fix
>
> Bug description:
> Since squid3 does an excellent job in proxying and/or terminating
> HTTPS traffic it would be nice if the package by default would be
> compiled with ssl/tls support enabled.
>
> See: https://www.banym.de/linux/build-squid-with-enable-ssl-on-debian or
>
> http://www.d90.us/toolbox/2009/05/26/adding-ssl-support-to-squid-package-on-ubuntu/
>
> This was tested this with Ubuntu 10.04.4 LTS \n \l
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/squid3/+bug/1097032/+subscriptions
>

Micah Gersten (micahg) wrote :

I'm converting this to a wishlist request in line with the Debian bug.

Changed in squid3 (Ubuntu):
importance: Undecided → Wishlist
status: Won't Fix → Triaged
summary: - Build squid3 with –enable-ssl option by default
+ Please provide GNUTLS support in squid
Changed in squid3 (Debian):
status: Unknown → New
gliptak (gliptak) wrote :

Is this also duplicate of https://bugs.launchpad.net/bugs/16669 ?

Changed in squid3 (Debian):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.