squid upgrade breaks if 'cache_dir null' in use

Bug #800468 reported by Adam Levin on 2011-06-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
squid (Ubuntu)
Low
James Page

Bug Description

I upgraded from an old, no longer supported version (I think it was 8.10, might have been 9.04) to 10.04 LTS with no problem. Then I upgraded to 10.10 immediately after that, and started having problems at the end of the install where it failed and didn't clean up. Finally, I upgraded to 11.04 and the same problem occurred (error at the very end of the upgrade before cleanup). I manually cleaned up with apt-get autoremove etc. I'm still getting an error with squid, though it seems to work. I tried apt-get remove and then reinstalling squid, but I get an error when reinstalling. However, again, it still seems to run.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: squid 2.7.STABLE9-2.1ubuntu6
ProcVersionSignature: Ubuntu 2.6.38-8.42-server 2.6.38.2
Uname: Linux 2.6.38-8-server x86_64
Architecture: amd64
Date: Mon Jun 20 21:06:01 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
SourcePackage: squid
Title: package squid 2.7.STABLE9-2.1ubuntu6 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to natty on 2011-06-20 (1 days ago)

Related branches

Adam Levin (levins0) wrote :
James Page (james-page) wrote :

Error from log:

Setting up squid (2.7.STABLE9-2.1ubuntu6) ...
stat: cannot stat `no-store': No such file or directory
stat: cannot stat `no-store': No such file or directory
chown: cannot access `no-store': No such file or directory
dpkg: error processing squid (--configure):
 subprocess installed post-installation script returned error exit status 1

James Page (james-page) wrote :

Hi Adam

Thank you for taking the time to report this bug and helping to make Ubuntu better.

It looks like the upgrade process may not be handling something specific to your squid configuration very well.

Please could you attach /etc/squid/squid.conf to this bug report.

Thanks

Changed in squid (Ubuntu):
status: New → Incomplete
Adam Levin (levins0) wrote :
James Page (james-page) wrote :

OK so its this part of your configuration which is causing the problem:

cache_dir null no-store

I believe this should be dealt with during an upgrade

summary: - package squid 2.7.STABLE9-2.1ubuntu6 failed to install/upgrade:
- subprocess installed post-installation script returned error exit status
- 1
+ squid upgrade breaks if cache_dir null in use
summary: - squid upgrade breaks if cache_dir null in use
+ squid upgrade breaks if 'cache_dir' null in use
summary: - squid upgrade breaks if 'cache_dir' null in use
+ squid upgrade breaks if 'cache_dir null' in use
Changed in squid (Ubuntu):
status: Incomplete → Confirmed
James Page (james-page) wrote :

The issue is that the post installation script attempts to chown the cache_dir directory with appropriate permissions; however as cache_dir null does not have a directory type it tried to chown the next argument which in this configuration is no-store.

James Page (james-page) wrote :

Adam

You could work around this by re-enabling the original cache_dir configuration option during the upgrade and then restoring your configuration once it had been completed.

Changed in squid (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
James Page (james-page) wrote :

Thanks for reporting this bug and any supporting documentation.

Since this bug has enough information provided for a developer to begin work, I'm going to mark it as 'Triaged and let them handle it from here. As the workaround is relatively easier I've set its importance as 'Low'.

Thanks for taking the time to make Ubuntu better!

James Page (james-page) on 2011-06-23
Changed in squid (Ubuntu):
assignee: nobody → James Page (james-page)
status: Triaged → In Progress
Adam Levin (levins0) wrote :

Great, James. I'm glad I could help out. I wouldn't think there are a lot of people running squid without the cache, but my situation is a bit unique, so it figures I'd find something a bit obscure. It should be an easy fix, and thankfully the rest of the upgrade went fine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE9-4ubuntu2

---------------
squid (2.7.STABLE9-4ubuntu2) oneiric; urgency=low

  * debian/postinst, debian/config:
    - Fix upgrade failures where cache_dir type of null is in use by
      checking that cache_dir points at a real directory or symbolic
      link (LP: #800468).
 -- James Page <email address hidden> Fri, 24 Jun 2011 12:40:46 +0100

Changed in squid (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers