package squid 2.7.STABLE9-2.1ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 100

Bug #732314 reported by Chris Halse Rogers on 2011-03-09
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
squid (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: squid

Today's (10/3/2011) update breaks on squid - it seems to be trying to run a missing init script.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: squid 2.7.STABLE9-2.1ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
AptOrdering:
 libgl1-mesa-glx: Install
 squid: Configure
 libgl1-mesa-glx: Configure
Architecture: amd64
Date: Thu Mar 10 10:00:09 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 100
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110117)
SourcePackage: squid
Title: package squid 2.7.STABLE9-2.1ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 100
UpgradeStatus: Upgraded to natty on 2011-03-08 (1 days ago)

Related branches

Chris Halse Rogers (raof) wrote :
Serge Hallyn (serge-hallyn) wrote :

Thanks for taking the time to submit this bug and helping to make Ubuntu better.

Could you show us the result of

 ls /etc/init.d

and tell us whether now doing a

 apt-get install -f

gets past the issue?

Changed in squid (Ubuntu):
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

output of /etc/init.d, script quid is missing from that directory.

Jean-Baptiste Lallement (jibel) wrote :

and apt-get -f install doesn't get past this error because it seems to be due to a missing script
Setting up squid (2.7.STABLE9-2.1ubuntu4) ...
invoke-rc.d: unknown initscript, /etc/init.d/squid not found.
invoke-rc.d: unknown initscript, /etc/init.d/squid not found.
dpkg: error processing squid (--configure):
 subprocess installed post-installation script returned error exit status 100

Changed in squid (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Clint Byrum (clint-fewbar) wrote :

This is happening because squid doesn't use dh_installinit so the symlink to /lib/init/upstart-job has to be created manually. Proposing a merge shortly that solves the issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE9-2.1ubuntu5

---------------
squid (2.7.STABLE9-2.1ubuntu5) natty; urgency=low

  * Fix missing symlink to upstart-job in /etc/init.d (LP: #732314)
 -- Clint Byrum <email address hidden> Thu, 10 Mar 2011 08:23:00 -0800

Changed in squid (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers