squid is not started on runlevel transition 1 -> 2

Bug #561779 reported by Ernst Kloppenburg on 2010-04-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
squid (Ubuntu)
Medium
Clint Byrum
Lucid
Medium
Unassigned
Maverick
Medium
Unassigned
Natty
Medium
Clint Byrum

Bug Description

Binary package hint: squid

when you go to runlevel 1 for maintenance with 'telinit 1', squid is stopped correctly

when you go back to runlevel 2 with 'telinit 2' squid is not started
because /etc/init/squid.conf does not contain a condition for that.

in karmic, squid would stop on entering runlevel 1 and be started again on entering runlevel 2

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: squid 2.7.STABLE7-1ubuntu11
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Mon Apr 12 21:48:49 2010
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: squid

Mathias Gug (mathiaz) on 2010-04-14
Changed in squid (Ubuntu):
importance: Undecided → Low

Is it low importance? It's easily worked around if I know it occurs, but if I don't know this bug exists then I'm left with a server at runlevel 2 without squid, and it may cause users all kinds of problems before they get back to me and I work out what's wrong.

João Pinto (joaopinto) wrote :

Manually changing runlevel is something that only an experienced user will do, and such person will be able to workaround the problem. IMO it's a low importance problem.

It isn't a matter of being able to work around the problem; an experienced user can do that, I agree. As I pointed out, it's that squid not running on moving to run level 2 isn't obvious to the admin that's just made the change. It has to affect users before the admin gets to know about the problem and investigate. A bug which affects the users of the system before the admin notices, and the admin will then have to spend time investigating *why* squid isn't running, doesn't seem low priority. Working around the bug is trivial, it's the upset and work it causes before the workaround stage is reached that's the problem.

Runlevel changes have been an essential functionality of unix / linux for a long time. You could use them for regular administration tasks.

Now this stopped to work. This bug is a regression.

Clint Byrum (clint-fewbar) wrote :

Marking this bug as Triaged. This is a problem in the upstart script that only exists in the Ubuntu package, and so there's no other upstream for it. This was one of the first services ported to upstart and so we're learning a lot through fixing the bugs in its upstart job and surrounding maintainer scripts. The appropriate start on line is 'start on runlevel [2345]' which will alleviate this problem and retain the same conditions as are stated explicitly in the file.

tags: added: regression-release
tags: added: upstart
Changed in squid (Ubuntu):
status: New → Triaged
importance: Low → Medium
Clint Byrum (clint-fewbar) wrote :

Also raising the importance to Medium, and tagging regression-release. I'm sure hardy users, on upgrade to lucid, will be surprised to see that their single user mode changes aren't properly handled.

Changed in squid (Ubuntu Maverick):
importance: Undecided → Medium
status: New → Triaged
Changed in squid (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
Changed in squid (Ubuntu Natty):
assignee: nobody → Clint Byrum (clint-fewbar)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE9-2.1ubuntu6

---------------
squid (2.7.STABLE9-2.1ubuntu6) natty; urgency=low

  * debian/squid.upstart: start on changed to start on transition to
    runlevel 2 (LP: #561779)
  * debian/squid.upstart: SQUID_ARGS default value set to -D so DNS
    checks are not performed at startup (LP: #561750)
 -- Clint Byrum <email address hidden> Fri, 01 Apr 2011 13:59:06 -0700

Changed in squid (Ubuntu Natty):
status: In Progress → Fix Released

Hello Ernst, or anyone else affected,

Accepted squid into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in squid (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Ernst, or anyone else affected,

Accepted squid into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in squid (Ubuntu Maverick):
status: Triaged → Fix Committed

tested with lucid 10.04.3 -> OK

procedure:

with old package
- access the web through squid
- init 1
- init 2
- ps aux | grep squid # -> squid not running
with proposed package
- access the web through squid
- init 1
- init 2
- ps aux | grep squid # -> squid IS running
- access the web through squid -> works

tested with an up-to-date maverick system

same procedure as above -> OK

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE7-1ubuntu12.4

---------------
squid (2.7.STABLE7-1ubuntu12.4) lucid-proposed; urgency=low

  * d/squid.upstart: start on was not sufficient to restart squid
    on transition from runlevel 1 to 2 (LP: #561779). Also stop on
    condition was not sufficient to stop squid because of a missing
    space. (LP: #750371)
 -- Clint Byrum <email address hidden> Sat, 27 Aug 2011 03:20:45 -0700

Changed in squid (Ubuntu Lucid):
status: Fix Committed → Fix Released
Clint Byrum (clint-fewbar) wrote :

Just an FYI, these updates to lucid and natty also may cause a regression, see bug 831628 for more info.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE9-2ubuntu5.2

---------------
squid (2.7.STABLE9-2ubuntu5.2) maverick-proposed; urgency=low

  * d/squid.upstart: start on was not sufficient to restart squid
    on transition from runlevel 1 to 2 (LP: #561779). Also stop on
    condition was not sufficient to stop squid because of a missing
    space. (LP: #750371)
 -- Clint Byrum <email address hidden> Sat, 27 Aug 2011 02:21:34 -0700

Changed in squid (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers