[armel] squid FTBFS: cf_gen Segmentation fault

Bug #519897 reported by Kamal Mostafa on 2010-02-10
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
squid (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: squid

Internal build program cf_gen crashes with Segmentation fault in Ubuntu Lucid (only observed on [armel] platform):

http://launchpadlibrarian.net/39001967/buildlog_ubuntu-lucid-armel.squid_2.7.STABLE7-1ubuntu5_FAILEDTOBUILD.txt.gz

gcc -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -Wall -g -O2 -D_REENTRANT -o cf_gen cf_gen.o debug.o globals.o -L../lib -lmiscutil -lrt -lpthread -lm -lnsl
./cf_gen cf.data ./cf.data.depend
make[2]: *** [cf_parser.h] Segmentation fault
make[2]: *** Deleting file `cf_parser.h'
make[2]: Leaving directory `/build/buildd/squid-2.7.STABLE7/src'

Related branches

Chuck Short (zulcss) on 2010-02-22
Changed in squid (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Loïc Minier (lool) wrote :

Only happens when built with -O2; does not happen with -O0

Loïc Minier (lool) wrote :

22:41 < lool> zul: I got it to crash under qemu as well, but I couldn't gdb
              from the qemu-arm-static env, so I ran a real vm and there gdb
              would work but had no debug info

Chuck Short (zulcss) wrote :

I wasnt able to reproduce this on karmic.

Regards
chuck

Oliver Grawert (ogra) on 2010-02-25
tags: added: armel
Loïc Minier (lool) wrote :

Probably worth giving it another try with the newer gcc 4.4 which just got uploaded

Alexander Sack (asac) wrote :

would be good to have this fixed ... probably toolchain issue.

Changed in squid (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
milestone: ubuntu-10.04-beta-1 → none

Building squid still crashes with current gcc on armel, and I do not have the root cause yet. Although I do not know if we want to do this, I did a small change for debian/rules to build with -O0 for arm, and this at least does work, as Loic noted much earlier. So I have attached it here.

Chuck Short (zulcss) on 2010-03-19
Changed in squid (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE7-1ubuntu8

---------------
squid (2.7.STABLE7-1ubuntu8) lucid; urgency=low

  [David Sugar]
  * debian/rules: disable optimization for arm (LP: #519897)

  [Chuck Short]
  * debian/rules: Default NUMJOBS to 1.
 -- Chuck Short <email address hidden> Tue, 16 Mar 2010 08:30:22 -0400

Changed in squid (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers