Please merge squid_2.7.STABLE3-4.1(main) from debian unstable

Bug #326547 reported by Bhavani Shankar on 2009-02-07
2
Affects Status Importance Assigned to Milestone
squid (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: squid

Debian has a new version to be merged

quid (2.7.STABLE3-4.1) unstable; urgency=high

  * Non-maintainer upload by the security team
  * Include upstream patch to fix DoS via error in request processing
    code (Closes: #514142)

 -- Steffen Joeris <email address hidden> Thu, 05 Feb 2009 18:28:57 +0000

squid (2.7.STABLE3-4) unstable; urgency=low

  * debian/rules
    - Limit parallel building to the build: section (Closes: #512512)

 -- Luigi Gangitano <email address hidden> Wed, 2 Feb 2009 02:53:03 +0100

squid (2.7.STABLE3-3) unstable; urgency=low

  * debian/patches/61-upgrade-http0.9-option
    - Added upstream patch adding an option that fixes issue with streaming
      (Closes: #512287)

  * debian/logrotate
    - Removed reference to /usr/sbin/sarg-maint which is not in sarg anymore
      (Closes: 462932)

  * debian/squid.overrides
    - Updated override of lintian warnings for setgid binaries needed for auth

  * debian/squid.resolvconv
    - Call init.d script using invoke-rc.d

 -- Luigi Gangitano <email address hidden> Wed, 21 Jan 2009 01:35:06 +0100

Related branches

Bhavani Shankar (bhavi) wrote :
Changed in squid:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE3-4.1ubuntu1

---------------
squid (2.7.STABLE3-4.1ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes: LP: #326547
    - 99-ubuntu-ssl-cert-snakeoil:
      + src/cf.data.pre:
        * Add refrence to snakepil /etc/ssl
    - debian/control:
      + Add ssl-cert to Depends to bring in snakeoil certificates.
    - debian/logrotate: use sarg-reports rather than sarg-maint.
      (LP: #268816)
    - Only pass -j$(NUMJOBS) to "$(MAKE) all" and not in MAKEFLAGS as
      debian/rules isn't -j safe; see Debian #512512.

squid (2.7.STABLE3-4.1) unstable; urgency=high

  * Non-maintainer upload by the security team
  * Include upstream patch to fix DoS via error in request processing
    code (Closes: #514142)

squid (2.7.STABLE3-4) unstable; urgency=low

  * debian/rules
    - Limit parallel building to the build: section (Closes: #512512)

squid (2.7.STABLE3-3) unstable; urgency=low

  * debian/patches/61-upgrade-http0.9-option
    - Added upstream patch adding an option that fixes issue with streaming
      (Closes: #512287)

  * debian/logrotate
    - Removed reference to /usr/sbin/sarg-maint which is not in sarg anymore
      (Closes: 462932)

  * debian/squid.overrides
    - Updated override of lintian warnings for setgid binaries needed for auth

  * debian/squid.resolvconv
    - Call init.d script using invoke-rc.d

 -- Bhavani Shankar <email address hidden> Sat, 07 Feb 2009 18:08:10 +0530

Changed in squid:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers