squid-deb-proxy 0.6 fails to install on precise

Bug #893313 reported by Adam Gandelman on 2011-11-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
squid-deb-proxy
Fix Released
Undecided
Unassigned
squid-deb-proxy (Ubuntu)
Undecided
Unassigned

Bug Description

This is presumably due to demotion of squid in favor of squid3. I'm assuming the squid.conf shipped with squid-deb-proxy will need to be adjusted accordingly.

ubuntu@avahi-service:~$ sudo apt-get -y install squid-deb-proxy
[sudo] password for ubuntu:
Sorry, try again.
[sudo] password for ubuntu:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libopenais3 linux-headers-3.0.0-12 libpython2.6 linux-headers-3.0.0-12-server
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  avahi-daemon avahi-utils libavahi-core7 libdaemon0 libnss-mdns
Suggested packages:
  avahi-autoipd
The following NEW packages will be installed:
  avahi-daemon avahi-utils libavahi-core7 libdaemon0 libnss-mdns squid-deb-proxy
0 upgraded, 6 newly installed, 0 to remove and 22 not upgraded.
Need to get 263 kB of archives.
After this operation, 1,076 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/main libavahi-core7 amd64 0.6.30-5ubuntu1 [112 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise/main libdaemon0 amd64 0.14-2 [18.9 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ precise/main avahi-daemon amd64 0.6.30-5ubuntu1 [69.1 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ precise/main avahi-utils amd64 0.6.30-5ubuntu1 [30.0 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ precise/main libnss-mdns amd64 0.10-3.2 [24.7 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ precise/universe squid-deb-proxy all 0.6 [8,554 B]
Fetched 263 kB in 2s (89.1 kB/s)
Preconfiguring packages ...
Selecting previously unselected package libavahi-core7.
(Reading database ... 92681 files and directories currently installed.)
Unpacking libavahi-core7 (from .../libavahi-core7_0.6.30-5ubuntu1_amd64.deb) ...
Selecting previously unselected package libdaemon0.
Unpacking libdaemon0 (from .../libdaemon0_0.14-2_amd64.deb) ...
Selecting previously unselected package avahi-daemon.
Unpacking avahi-daemon (from .../avahi-daemon_0.6.30-5ubuntu1_amd64.deb) ...
Selecting previously unselected package avahi-utils.
Unpacking avahi-utils (from .../avahi-utils_0.6.30-5ubuntu1_amd64.deb) ...
Selecting previously unselected package libnss-mdns.
Unpacking libnss-mdns (from .../libnss-mdns_0.10-3.2_amd64.deb) ...
Selecting previously unselected package squid-deb-proxy.
Unpacking squid-deb-proxy (from .../squid-deb-proxy_0.6_all.deb) ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for man-db ...
Setting up libavahi-core7 (0.6.30-5ubuntu1) ...
Setting up libdaemon0 (0.14-2) ...
Setting up avahi-daemon (0.6.30-5ubuntu1) ...
avahi-daemon start/running, process 2968
Setting up avahi-utils (0.6.30-5ubuntu1) ...
Setting up libnss-mdns (0.10-3.2) ...
First installation detected...
Checking NSS setup...
Setting up squid-deb-proxy (0.6) ...
start: Job failed to start
invoke-rc.d: initscript squid-deb-proxy, action "restart" failed.
start: Job failed to start
invoke-rc.d: initscript squid-deb-proxy, action "start" failed.
dpkg: error processing squid-deb-proxy (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 squid-deb-proxy
E: Sub-process /usr/bin/dpkg returned an error code (1)
ubuntu@avahi-service:~$

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid-deb-proxy - 0.6.1

---------------
squid-deb-proxy (0.6.1) precise; urgency=low

  [ Adam Gandelman ]
  * debian/squid-deb-proxy.upstart: Wrap squid execution in a script section.
    Also test for location/version of squid there, as the existing test in
    pre-start is out of scope but needed in both places. (LP: #893313)
 -- Michael Vogt <email address hidden> Thu, 24 Nov 2011 16:26:34 +0100

Changed in squid-deb-proxy (Ubuntu):
status: New → Fix Released
Changed in squid-deb-proxy:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers