squid-deb-proxy does not refresh translation files often enough

Bug #1474417 reported by Scott Moser on 2015-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
maas (Ubuntu)
High
Unassigned
squid-deb-proxy (Ubuntu)
Medium
Michael Vogt

Bug Description

per conversation with mvo:

<smoser> i'm remembering (possibly faultily) that apt at some point changed to checking hashsums of translation files when it previously did not.
<smoser> did i make that up ?
<mvo> hey
<mvo> it does check them now, yes
<smoser> and it did not before, right?
<mvo> well, it always did but we did not include the hashes in the release file in the past
<smoser> ah. that'd be why i didn't fine any thing in git logs of apt
<mvo> which is not quiete correct we did include a hash to a i18n/index file or something that contained the hashes
<mvo> yeah, it was only a issue with LP
<smoser> http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/wily/squid-deb-proxy/wily/view/head:/squid-deb-proxy.conf
<smoser> so in squid-deb-proxy.conf, essentially we should now have the translation files as 'refresh-ims'
<mvo> oh, this needs updates for translations now I guess?
<mvo> absolutely
<smoser> (ie, an entry around line 60, right ?)
<smoser> yeah.
<mvo> thanks for bringing this up

Related bugs:
 * bug 1313576: Add hashes for Translation-$lang into the Release file

Related branches

Scott Moser (smoser) on 2015-07-14
Changed in squid-deb-proxy (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Michael Vogt (mvo)
Scott Moser (smoser) on 2015-07-14
Changed in maas (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Scott Moser (smoser) wrote :

attaching a diff from squid-deb-proxy.conf [1] to debian/extras/maas-proxy.conf [2]

[1] http://bazaar.launchpad.net/~squid-deb-proxy-developers/squid-deb-proxy/trunk/view/head:/squid-deb-proxy.conf
[2] http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/wily/maas/wily/view/head:/debian/extras/maas-proxy.conf

$ mydiff() { myd=$(mktemp -d); for f in "$1" "$2"; do grep -v "^#" "$f" | sort -u > "$myd/${f##*/}"; done; diff -u "${myd}/${1##*/}" "${myd}/${2##*/}"; rm -Rf "$myd"; }
$ mydiff squid-deb-proxy.conf debian/extras/maas-proxy.conf

Pay particular difference to refresh_pattern:
-refresh_pattern changelogs.ubuntu.com\/.* 0 1% 1
-refresh_pattern deb$ 129600 100% 129600
-refresh_pattern \/InRelease$ 0 0% 0 refresh-ims
-refresh_pattern \/(Packages|Sources)(|\.bz2|\.gz|\.xz)$ 0 0% 0 refresh-ims
-refresh_pattern \/Release(|\.gpg)$ 0 0% 0 refresh-ims
-refresh_pattern tar.bz2$ 129600 100% 129600
-refresh_pattern tar.gz$ 129600 100% 129600
-refresh_pattern tar.xz$ 129600 100% 129600
-refresh_pattern \/(Translation-.*)(|\.bz2|\.gz|\.xz)$ 0 0% 0 refresh-ims
-refresh_pattern udeb$ 129600 100% 129600
+refresh_pattern . 0 20% 4320
+refresh_pattern ^ftp: 1440 20% 10080
+refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
+refresh_pattern (Release|Packages(.gz)*)$ 0 20% 2880

The new change for squid-deb-proxy.conf is the addition of the Translation line.
Note other differences:
 * maas-proxy does not pay special attention to .bz2 or .xz files (only .gz)
 * maas-proxy does not pay special attention to .gpg files
 * squid-deb-proxy uses 'refresh-ims' while maas's version does not.

http://www.squid-cache.org/Doc/config/refresh_pattern/ has info on what those lines are (refresh_pattern regex min max [options])

Michael Vogt (mvo) wrote :

@Scott - I wonder if you could just import the proxy config from squid-deb-proxy as part of the maas-proxy build process? If its following the squid-deb-proxy settings anyway?

Changed in squid-deb-proxy (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid-deb-proxy - 0.8.12

---------------
squid-deb-proxy (0.8.12) unstable; urgency=medium

  * squid-deb-proxy.conf:
    - handle Translation-.* the same way as the other indexfiles
      (LP: #1474417). Thanks to Scott Moser.

 -- Michael Vogt <email address hidden> Thu, 16 Jul 2015 09:13:03 +0200

Changed in squid-deb-proxy (Ubuntu):
status: In Progress → Fix Released
Scott Moser (smoser) wrote :

Michael, wrt import at build time, i dont think we can use squid-deb-proxy straight away. we could come up with some way of separating out "apt specific" and pulling only those, but maas has other reasons to diverge for othe rthings.

i think unnecessary to do some automation here due to the low rate of change.

description: updated
Changed in maas (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers