squid-deb-proxy fails to resolve dns entry : needs to be restarted

Bug #1456662 reported by Louis Bouchard on 2015-05-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
squid-deb-proxy (Ubuntu)
Medium
Unassigned
Trusty
Medium
Louis Bouchard

Bug Description

[SRU justification]
In some race situation, squid-deb-proxy is unable to operate and needs to be restarted.

[Impact]
Requires manual intervention from system administrator to function correctly.

[Fix]
Change the "start on" upstart statement to match the one used by squid3

[Test Case]
See Original description.

[Regression]
None expected as the same statement is already in use in the squid3 package and in the upstream debian package.

[ORiginal description of the problem]

In some specific context that I currently cannot identify (i.e. happens everytime on my server but never in VMs), after a reboot, squid-deb-proxy fails to resolve DNS entries for URL that it needs to service. The problem seems systematic on the hardware that I have.

Release : Trusty (squid-deb-proxy_0.8.6)

Test :
1) Reboot squid-deb-proxy server
2) From some client, issue :
$ telnet {squid-deb-proxy-server} 8000
GET http://fr.archive.ubuntu.com/ubuntu/dists/wily/InRelease
Trying 192.168.1.11...
Connected to avogadro.
Escape character is '^]'.
HTTP/1.1 503 Service Unavailable
Server: squid/3.3.8
Mime-Version: 1.0
Date: Tue, 19 May 2015 14:21:51 GMT
Content-Type: text/html
Content-Length: 3287
X-Squid-Error: ERR_DNS_FAIL 0
Vary: Accept-Language
Content-Language: en
X-Cache: MISS from squid-deb-proxy
X-Cache-Lookup: MISS from squid-deb-proxy:8000
Via: 1.1 squid-deb-proxy (squid/3.3.8)
Connection: close
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html><head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title>ERROR: The requested URL could not be retrieved</title>
<style type="text/css"><!--
 /*
 Stylesheet for Squid Error pages
 Adapted from design by Free CSS Templates
 http://www.freecsstemplates.org
 Released for free under a Creative Commons Attribution 2.5 License
*/
...
<div id="content">
<p>The following error was encountered while trying to retrieve the URL: <a href="http://fr.archive.ubuntu.com/ubuntu/dists/wily/InRelease">http://fr.archive.ubuntu.com/ubuntu/dists/wily/InRelease</a></p>

<blockquote id="error">
<p><b>Unable to determine IP address from host name <q>fr.archive.ubuntu.com</q></b></p>
</blockquote>

<p>The DNS server returned:</p>
<blockquote id="data">
<pre>No DNS records</pre>
</blockquote>

<p>This means that the cache was not able to resolve the hostname presented in the URL. Check if the address is correct.</p>

<p>Your cache administrator is <a href="mailto:webmaster?subject=CacheErrorInfo%20-%20ERR_DNS_FAIL&amp;body=CacheHost%3A%20squid-deb-proxy%0D%0AErrPage%3A%20ERR_DNS_FAIL%0D%0AErr%3A%20%5Bnone%5D%0D%0ADNS%20ErrMsg%3A%20No%20DNS%20records%0D%0ATimeStamp%3A%20Tue,%2019%20May%202015%2014%3A21%3A51%20GMT%0D%0A%0D%0AClientIP%3A%20192.168.1.10%0D%0A%0D%0AHTTP%20Request%3A%0D%0AGET%20%2Fubuntu%2Fdists%2Fwily%2FInRelease%20HTTP%2F0.9%0A%0D%0A%0D%0A">webmaster</a>.</p>
<br>

Restarting the squid-deb-proxy service fixes the problem

Louis Bouchard (louis) on 2015-05-19
Changed in squid-deb-proxy (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in squid-deb-proxy (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Louis Bouchard (louis-bouchard)
description: updated
tags: added: sts
Louis Bouchard (louis) wrote :

Using the same "start on " clause than for the squid3 job fixes the problem (start on runlevel ...) :

 # squid-deb-proxy - a proxy for deb packages
 #

 description "squid-deb-proxy"
 start on runlevel [2345]
 stop on runlevel [!2345]

I am going to prepare a debdiff with that modification

Louis Bouchard (louis) wrote :

As it turns out, mvo has just uploaded the fix along with some other bug fix for this bug : http://bugs.debian.org/780083 to Debian this morning. So I will pick up his changes from Wily and SRU it when it becomes available

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid-deb-proxy - 0.8.11

---------------
squid-deb-proxy (0.8.11) unstable; urgency=low

  [ Vagrant Cascadian ]
  * add /etc/resolvconf/update-libc.d/squid-deb-proxy (closes: #780083)

  [ Robie Basak ]
  * Simplify upstart "start on" to match squid3, to fix runlevel
    transition problem (LP: #1456662)

 -- Michael Vogt <email address hidden> Wed, 27 May 2015 09:12:49 +0200

Changed in squid-deb-proxy (Ubuntu):
status: Confirmed → Fix Released
Louis Bouchard (louis) wrote :

debdiff from the fix in Wily

description: updated

Hello Louis, or anyone else affected,

Accepted squid-deb-proxy into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/squid-deb-proxy/0.8.6ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in squid-deb-proxy (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Louis Bouchard (louis) on 2015-06-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid-deb-proxy - 0.8.6ubuntu1

---------------
squid-deb-proxy (0.8.6ubuntu1) trusty-proposed; urgency=medium

  [ Vagrant Cascadian ]
  * add /etc/resolvconf/update-libc.d/squid-deb-proxy (closes: #780083)

  [ Robie Basak ]
  * Simplify upstart "start on" to match squid3, to fix runlevel
    transition problem (LP: #1456662)

 -- Louis Bouchard <email address hidden> Tue, 02 Jun 2015 11:24:16 +0200

Changed in squid-deb-proxy (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for squid-deb-proxy has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.