Squeak package missing sound plugins

Bug #235146 reported by ckasso on 2008-05-27
6
Affects Status Importance Assigned to Milestone
squeak-vm (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: squeak-vm

Ubuntu 8.04
package squeak-vm 1:3.9.8-3ubuntu1
/usr/lib/squeak/3.9-8 should contain vm-sound-ALSA and vm-sound-OSS

Oliver Grawert (ogra) wrote :

we dont support OSS in ubuntu at all, but i agree if sound should be broken due to missing alsa plugins we need to add them

Markus Schlager (m-slg) wrote :

I can confirm this bug. Adding these two files solved some problems e.g. running a Scratch-Image with squeak.

Peter Tillemans (pti-snamellit) wrote :

Adding libasound2-dev to Build-Depends creates the 2 files during a rebuild

Peter Tillemans (pti-snamellit) wrote :

same on amd64. submitted possible solution in comment

Changed in squeak-vm:
status: New → Confirmed
LaserJock (laserjock) wrote :

Bug #254547 will probably have to be fixed first. :-)

As of 15 April 2009 this is still a current problem.

I recently started with a fresh Ubuntu 8.04 distirbution.
I am new to Ubuntu (old hand at squeak on a Mac).

I have described my problems on the squeak-dev list starting here.
http://lists.squeakfoundation.org/pipermail/squeak-dev/2009-April/135478.html

Other recent posts can be found here by searching for Ubuntu in the title.
http://lists.squeakfoundation.org/pipermail/squeak-dev/2009-April/

I have done enough experimentation with the problem to discover some workarounds.

However the problem itself needs to be solved for the squeak distribution and the vm distributed with it.

So questions:

When I ask Add/Remove to search all available applications for "squeak" what package does it find and where is that package located. That is the location and the package that needs fixing.

The fix for sound is to include the missing plugins
vm-sound-OSS and
vm-sound-ALSA (if is spelled that right).

That is the difference between the etoys distribution and squeaks that affects sound.

The other question I have is
How can that be fix NOW?

This is a blocking level problem not only for squeak but also for scratch.

Hi I posted this to the squeak-dev list
http://lists.squeakfoundation.org/pipermail/squeak-dev/2009-April/135757.html
but I was really trying to get it to the attn: of Jordan Mantha.
The email address I had been given for him bounced. So I am repeating the post here.
If someone can bring it to his attention I would appreciate some response. --Jer

Jerome Peace, bug tracker here.

I recently started using squeak on a Ubuntu system. I am old to squeak but new to Ubuntu and Linux.

So everything about setting up is new.

Presently loading what Ubuntu offers as a download causes squeak to operate without sound. The vm-sound-ASLA and vm-sound-OSS plugins do not come with the offered package. This has been a problem for over a year.

I am pushing to find someone to act on a solution that solves the problem, not just for myself but for all other naive Ubuntu users who just want to use squeak.

Proof that the solution is in place will be to download and install the Ubuntu offered squeak and have it work with sound.

I have written the squeak-dev list and you can find the posts in the April 2009 archives by searching for Ubuntu.
http://lists.squeakfoundation.org/pipermail/squeak-dev/2009-April/date.html

You were mentioned by Matej Kosik as the maintainer of the Ubuntu distribution. So I am writing you to let you know what is going on.

Any help you can offer will be appreciated. Copying your replies to the list will be helpful.

The actions I would like to see taken are these.

1) The priority of the bug on launchpad should be changed from
undecided to major or blocking. Computers can interface with users only through the sense of sight or sound. To be missing one of them blocks half of their abilities.

2) Sound can be restored to future downloads by simply coping the
vm-sound-ALSA plugin from the Etoys distribution into the squeak distribution ( the copied file to be named vm-sound-ALSA.so to go along with the naming scheme.) Nothing more than that is needed to solve this bug.*

3) An update should be made available to 8.04 LTS and others that
checks for the squeak package, checks the squeak vmplugin library
iff vm-sound-ALSA.so is missing it recreates and installs that file.

4) These actions taken with the priority implied in step 1.

This fix would probably fix problem that MIT's Scratch is having as well.

Yours in curiosity and service, --Jerome Peace

*You may have a wish to recreate the plugin from source. I imagine the source for the Etoys plugin would do for a start. Or others more knowledgable than I could point to it. The existing binaries have worked fine in my tests.

My main point is that this is a serious enough bug that it deserves to be squashed NOW without further delay.

David Farning (dfarning) on 2010-08-24
Changed in squeak-vm (Ubuntu):
importance: Undecided → Low
TJ (tj) wrote :

Since 8.04 LTS is no longer supported on the desktop I'm marking this Won't Fix.

12.04 LTS includes the missing libraries:

$ dpkg-query -L squeak-vm | grep sound
/usr/lib/squeak/4.4.7-2357/so.vm-sound-pulse
/usr/lib/squeak/4.4.7-2357/so.vm-sound-null
/usr/lib/squeak/4.4.7-2357/so.vm-sound-OSS
/usr/lib/squeak/4.4.7-2357/so.vm-sound-custom
/usr/lib/squeak/4.4.7-2357/so.vm-sound-ALSA

Changed in squeak-vm (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers