spread init script sets invalid conf file location

Bug #191849 reported by Petr Sodomka
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
spread (Ubuntu)
Confirmed
Low
Unassigned

Bug Description

Binary package hint: spread

I've installed "spread" package in latest Ubuntu. When I tried to start it, the daemon didn't start.

There is a configuration error inside /etc/init.d/spread. Package installs its configuration file to /etc/spread/spread.conf but inside the init script, there is a line DOPTIONS="-c /etc/spread.conf". There should be DOPTIONS="-c /etc/spread/spread.conf" intead. Notice the added directory "spread". When corrected, spread daemon sucessfully starts (you have to set ENABLED=1 in /etc/default/spread if you want to repeat my steps)

---- how to reproduce:

apt-get install spread
(..edit /etc/default/spread, set ENABLED=1)
(..check there is /var/run/spread directory with chown spread:spread)
/etc/init.d/spread start
ps ax | grep spred
(..you will see it's not running)

----- how to fix
(.. edit /etc/init.d/spread and set DOPTIONS="-c /etc/spread/spread.conf")
/etc/init.d/spread start
ps ax | grep spred
(.. spread is running now! success)

Tags: patch
Revision history for this message
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in spread:
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in spread:
status: Incomplete → Invalid
Revision history for this message
Petr Sodomka (pesmail2003) wrote :

Yes, it is still there! In the 8.10

I've included a fix, so is it a big problem to apply it and fix this bug?

Just change line inside /etc/init.d/spread

from:

DOPTIONS="-c /etc/spread.conf"

to:

DOPTIONS="-c /etc/spread/spread.conf"

as you can see in the package contents, there is a file /etc/spread/spread.conf and NOTa file /etc/spread.conf

Does it make sense now?

I'm trying to help to make Ubuntu better, why are you closing this bug as "invalid"? The required information to fix it was in my first post!

Thank you.

Changed in spread:
status: Invalid → New
Revision history for this message
Þórir Magnússon (thorir) wrote :

I can confirm this bug and it is also in 9.04

The spread is not working in Ubuntu as it is and I have to fix it everytime I install new machine.

Regards

Revision history for this message
Petr Sodomka (pesmail2003) wrote :

It's nearly two years now from the time I've filled this bug. It's still present in Ubuntu Karmic Koala 9.10. I've already wrote, how this can be fixed. But nothing happened.

What can I do to fix it myself in the affected package?

Revision history for this message
Reenen (reenen) wrote :

This is also in Ubuntu 10.04.1 LTS

Also, since the config file binds to localhost, you need to set the process name with the -n switch for it to run. If not
it quits with:

 [Tue 17 Aug 2010 14:59:41] Conf_init: My proc id (127.0.1.1) is not in configuration
 Exit caused by Alarm(EXIT)

I have attached a patch against the 10.04.1 sources.

tags: added: patch
Revision history for this message
AlexWinner (scukonick) wrote :

It also reproduces at 11.04.

Angel Abad (angelabad)
Changed in spread (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers