No driver for Samsung ML-1610 printer

Bug #59829 reported by x on 2006-09-10
12
Affects Status Importance Assigned to Milestone
foomatic-db (Ubuntu)
Medium
Unassigned
splix (Ubuntu)
Wishlist
Unassigned

Bug Description

Ubuntu 6.06 doesn't have a driver for Samsung ML-1610 printer.

I found out that there is a driver called Splix ( http://splix.ap2c.org/ ) (released 2006-08-25), which provides support for several different Samsung printers. It worked for ML-1610 so I'm making a feature request to add this driver to Ubuntu, so that users don't need to download and compile the drivers themselves.

Till Kamppeter (till-kamppeter) wrote :

Don't know whether we get it to feature freeze, but with the planned update of foomatic-db this printer will be at least set up with the GhostScript "gdi" driver.

Changed in foomatic-db:
status: Unconfirmed → Fix Released
status: Fix Released → Confirmed
status: Unconfirmed → Fix Released
Changed in foomatic-db:
importance: Undecided → Medium
Georg Sauthoff (g-sauthoff) wrote :

Hi,

don't know If I should open a new bug report for this:

I am using edgy edge 6.10 and I have a ml 1610 printer. The gdi driver is not an optimal fix for me. It is 'dog slow', i.e. after every page the printer takes a long break.

When I add the printer via the cupsd web frontend there are two printer drivers available for the ml 1610:
Foomatic/gdi
Foomatic/Postscript

When I choose Foomatic/Postrcript I get following error:
Error: Unable to copy PPD file!

In /var/log/cupsd/error.log I get this:
E [06/Dec/2006:17:18:00 +0100] copy_model: empty PPD file!

Best regards

Till Kamppeter (till-kamppeter) wrote :

If you have installed the SliX binary package linked in the previous post for testing, please uninstall it and install this one:

http://www.freestandards.org/~till/tmp/ubuntu/feisty/splix/binary/splix_1.0.1~beta2-0ubuntu1_i386.deb

I have corrected the version number notation (splix_1.0.1+beta2 -> splix_1.0.1~beta2) to make an update to the final 1.0.1 release of SpliX installing smoothly.

The source files are also replaced as I have done some packaging policy fixes.

Georg Sauthoff (g-sauthoff) wrote :

I have tested your src package with 6.10 and it works fine! Printing speed with this driver is the same like the Samsung binary linux or windows driver.

I built the src package via
dpkg-buildpackage -rfakeroot -uc -b
and got two very minor issues:
- 'Build-Depends:' doesn't include g++
  -> a manual apt-get install g++ solved it
- 'fakeroot debian/rules clean
/usr/bin/fakeroot: 152: debian/rules: Permission denied'
  -> a manual chmod u+x debian/rules solved it

Thanks!

Till Kamppeter (till-kamppeter) wrote :

Splix driver has been added to Feisty now.

Changed in splix:
status: Fix Released → In Progress
Changed in splix:
status: In Progress → Fix Committed
Changed in splix:
status: Fix Committed → Fix Released
Antoine Amarilli (a3nm) wrote :

I have the same printer and am having problems to make it work, I support this request.

Till Kamppeter (till-kamppeter) wrote :

Antoine, what is exactly your problem? Which version of Ubuntu are you using? If you are using Feisty, a general update would automatically install SpliX for you and you only need to remove and re-create your print queue to get your printer perfectly working.

If you have an older Ubuntu version you can either rebuild the source package as gsauthof describes in his posting or get a distribution-independent binary package of SpliX from OpenPrinting:

http://openprinting.org/show_driver.cgi?driver=splix
http://openprinting.org/download/printdriver/RPMS/i486/splix-1.0.1-1lsb3.1.i486.rpm

Make sure to follow these instructions:

http://www.linux-foundation.org/en/OpenPrinting/Database/DriverPackages

After having installed any version of SpliX described here, simply remove and re-create your print queue.

Antoine Amarilli (a3nm) wrote :

Hi,

Thanks for your help. I was able to get the driver to work under Edgy using your instructions (along with a few purges/reinstalls).

I apologize for the strange wording of my comment, I didn't notice that comments had already been posted before I added mine. I was answering the description and had not seen that splix had been actually included with Feisty.

Well, anyway, everything seems to work now, apart from the fact that the driver's settings appear in Italian for an unknown reason, but I can live with that.

Thanks again !

Antoine

First, you have italian descriptions because you have used the italian (it) version of the PPD file. There are also german (de), french (fr), and english (en) versions. In the printer setup tool you should see 4 entries for your printer with Splix, marked (de), (en), (fr), and (it). Choose the one for the language which you prefer.

Second, which instructions did you follow, the ones of getting the distribution-independent package from OpenPrinting or the ones of rebuilding the Feisty source package.

Which packages did you need to purge/re-install?

Antoine Amarilli (a3nm) wrote :

Hi,

I did see four entries for the driver in the printer setup tool, but the language was not indicated, I chose at random.

I followed the instructions to get the binary package from OpenPrinting.

I had to purge and reinstall cupsys, cupsys-common, foomatic-db and gs-esp. I must admit, through, that it probably would not have been needed on a clean install : I had tried before to use the Ubuntu GDI driver for the ML-1510, the Samsung proprietary driver, splix build from source, etc. (At some point the printer even worked, but it soon stopped to.)

Best regards

Antoine

Antoine Amarilli (a3nm) wrote :

PS : I purged the packages according to :
https://launchpad.net/ubuntu/+source/gs-esp/+bug/55283

The web interface of CUPS (http://localhost:631/) shows the language tags correctly, the gnome-cups-manager does not show them at all. This is a bug in the gnome-cups-manager. Report it as a new bug.

Antoine Amarilli (a3nm) wrote :

This bug has already been reported, I'm adding a comment to Bug #59829.

Antoine Amarilli (a3nm) wrote :

Sorry, I did it wrong, it's bug #37019.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers