Samsung ML-1710 will not print after upgrade

Bug #367650 reported by braigetori on 2009-04-26
8
Affects Status Importance Assigned to Milestone
splix (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: splix

After upgrading to 9.04, my printer will not print. An error message pops up saying: 'SpLiX Invalid PPD file version: SpLiX V. 2.0.0 but the PPD file is designed for SpLiX V. 2.0.0'

Here is the troubleshoot file: http://www.jrffinancial.com/ubuntuhelp/troubleshoot.txt

Thank you for your help,
:b

ok... fixed it. went to: http://www.samsung.com/ca/consumer/detail/support.do?group=printermultifunction&type=printermultifunction&subtype=monochromelaser&model_nm=ML-1630&disp_nm=ML-1630&language=&cate_type=all&dType=D&mType=DR&vType=&prd_ia_cd=06010400&model_cd=ML-1630/XAA&menu=download

get the linux unified linux driver. then go to: http://ubuntuforums.org/showthread.php?t=341621
and follow the instructions.

later !

braigetori (braigetori) on 2009-04-26
description: updated
braigetori (braigetori) on 2009-04-27
description: updated
Josh Danziger (josh-allducky) wrote :

I advise against the solution above. Installing the Samsung binary drivers will install several other libraries outside the purview of apt (e.g., qt libs, libstdc++5). A better solution is to reconfigure the printer.

Go to System => Administration => Printing, select your printer. Where the "Make and Model" of your printer is listed, select "Change..." to select a new print driver. Locate your printer, and click forward. You will be presented with a message titled "Existing Settings", to which you should answer "Use the new PPD (Postscript Printer Description) as is."

Printing a test page should now hopefully succeed (it did for me). Enjoy!

braigetori (braigetori) wrote :

thank you for the advice josh. you were correct to discourage this solution. i had a hell of a time trying to un-install the driver. apt updates would not work until i did: http://ubuntuforums.org/showthread.php?p=7161815

cheers !

;b

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package splix - 2.0.0-0.1ubuntu4

---------------
splix (2.0.0-0.1ubuntu4) karmic; urgency=low

  * debian/splix.postinst: Improved regexp for matching the Nickname in the
    PPDs of the existing print queues with the new PPDs of this package
    (LP: #367650)
  * debian/control: Added "cups" to Depends: as a running CUPS daemon is needed
    for the automatic update of existing print queues (LP: #367650).

 -- Till Kamppeter <email address hidden> Thu, 26 Mar 2009 16:57:49 +0100

Changed in splix (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) wrote :

Accepted splix into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers