[apport] splashy crashed with SIGSEGV

Bug #92276 reported by Alex Zvoleff
142
This bug affects 1 person
Affects Status Importance Assigned to Milestone
splashy (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: splashy

I tried to run splashy as a test, and it seg faulted.

ProblemType: Crash
Architecture: i386
Date: Wed Mar 14 09:08:03 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /sbin/splashy
Package: splashy 0.3.2
PackageArchitecture: i386
ProcCmdline: splashy test
ProcCwd: /etc/X11
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en_GB:en
ProcMaps:
 08048000-08210000 r-xp 00000000 08:06 511262 /sbin/splashy
 08210000-08216000 rw-p 001c7000 08:06 511262 /sbin/splashy
 08216000-0823d000 rw-p 08216000 00:00 0 [heap]
 bf97f000-bf994000 rw-p bf97f000 00:00 0 [stack]
 ffffe000-fffff000 r-xp 00000000 00:00 0 [vdso]
Signal: 11
SourcePackage: splashy
Stacktrace:
 #0 0x080b8a7a in ?? ()
 #1 0x00000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
ThreadStacktrace:
 .
 Thread 1 (process 21091):
 #0 0x080b8a7a in ?? ()
 #1 0x00000000 in ?? ()
Uname: Linux azvoleff-laptop 2.6.20-10-generic #2 SMP Mon Mar 12 00:02:49 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

Revision history for this message
Alex Zvoleff (azvoleff) wrote :
Changed in splashy:
importance: Undecided → Medium
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:splashy_stop_splash () at splashy_video.c:1267
cmd_exit (args=0x0) at splashy_functions.c:326
splashy_child_exit () at splashy_functions.c:1265
main (argc=) at splashy_main.c:137
__libc_start_main ()

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug

Changed in splashy:
status: Unconfirmed → Confirmed
Revision history for this message
Thomas Ohms (tohms) wrote :

Is there anything new to this bug?! Splashy doesn't work for me either on Feisty!

Revision history for this message
tutuca (tutuca) wrote :

Doesn't work on gutsy either
sudo splashy test returns

Splashy ERROR: Couldn't splashy_start_splashy(). Error -2

If it worth something

Revision history for this message
Freddy Martinez (freddymartinez9) wrote :

I can reproduce this on Kubuntu gutsy.

Revision history for this message
Freddy Martinez (freddymartinez9) wrote :

Still in Hardy.

Revision history for this message
xile (xile-email) wrote :

I have the same problem posted by Matias (Couldn't splashy_start_splashy(). Error -2)
I'm using Ubuntu 8.04b. Looks like the problem has been reported long ago but has never been solved. See: https://bugs.launchpad.net/ubuntu/+source/splashy/+bug/113833

Revision history for this message
Luis Mondesi (lemsx1) wrote :

I'm the main developer of Splashy and I use it with Hardy. Can somebody please confirm this bug for me?

I never realized there were bugs here for Splashy, as well as the Debian Bugs Tracking System.

Revision history for this message
Noam Lewis (lenoam) wrote :

I'm using Hardy 8.04.
Splashy fails with:
$ splashy test
Splashy ERROR: Couldn't splashy_start_splashy(). Error -2

but doesn't crash.

Revision history for this message
Luis Mondesi (lemsx1) wrote : Re: [Bug 92276] Re: [apport] splashy crashed with SIGSEGV

On Tue, Jul 22, 2008 at 10:40 AM, Noam Lewis <email address hidden> wrote:
> I'm using Hardy 8.04.
> Splashy fails with:
> $ splashy test
> Splashy ERROR: Couldn't splashy_start_splashy(). Error -2
>
> but doesn't crash.

This just means that you have not setup the framebuffer properly. See
our README file and the FAQ on the wiki:

http://splashy.alioth.debian.org/wiki/faq#i_don_t_see_any_image_at_boot_time

--
----)(-----
Luis Mondesi
Maestro Debiano

----- START ENCRYPTED BLOCK (Triple-ROT13) ------
Gur Hohagh [Yvahk] qvfgevohgvba oevatf gur fcvevg bs Hohagh gb gur
fbsgjner jbeyq.
----- END ENCRYPTED BLOCK (Triple-ROT13) ------

Revision history for this message
ginnyh532 (ginnyh532) wrote :

I am running the Intrepid alpha. I got the same error, Splashy ERROR: Couldn't splashy_start_splashy(). Error -2.

Revision history for this message
neo (tkolodziejski) wrote :

I get similar error on my Intrepid:

dmesg | grep splash:
[ 0.000000] Kernel command line: root=UUID=e98a725d-be4f-4693-a031-208e9326e944 ro quiet splash
[ 13.404808] splashy[2473]: segfault at c ip b7fd127d sp bf905e60 error 4 in libsplashy.so.1.0.0[b7fcf000+5000]

Revision history for this message
Luis Mondesi (lemsx1) wrote :

Splashy 0.3.12 was released and there is an Ubuntu Hardy package at the Alioth server:

http://alioth.debian.org/frs/?group_id=30657

This should work fine on Intrepid as well.

Revision history for this message
Daniel T Chen (crimsun) wrote :

fixed in jaunty

Changed in splashy:
status: Confirmed → Fix Released
Revision history for this message
neo (tkolodziejski) wrote :

It looks like fixed for me. I found http://splashy.alioth.debian.org/wiki/faq#i_don_t_see_any_image_at_boot_time mentioned by LuisMondesi and it works fine. And it doesn't crash any longer.

Revision history for this message
Daniel Dekovic (d-dekovic) wrote :

Splashy is giving this kind of segfaults and famous error -2 on system if frambuffer device wasn't setup. To see status of your framebuffer device use sudo dfbinfo or sudo hwlist --framebuffer. To set it up coment out in /etc/modprobe.d/blacklist-framebuffer vesafb, vga16fb and vfb and also put this modules in /etc/initramfs-tools/modules file. Then update your initramfs with update-initramfs -u and reboot. You can play with various resolution if you press e and edit grub conf file and put it in vga=ask or you can edit it before boot and run update-grub. Tested with kernel 2.6.27-9-generic and splashy 0.3.8-1 .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers