Ubuntu

Template translations not shipped with sphinx

Reported by David Fokkema on 2009-11-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
sphinx (Ubuntu)
Medium
Andrew Starr-Bochicchio

Bug Description

When I write documentation using sphinx and specify a language in conf.py, like:

# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
language = 'nl'

I get the error:

Running Sphinx v0.6.2
loading translations [nl]... locale not available

Upon further investigation, I see that sphinx.mo files are not included in the package.

ProblemType: Bug
Architecture: i386
Date: Wed Nov 11 21:37:30 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: python-sphinx 0.6.2-1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: sphinx
Uname: Linux 2.6.31-14-generic i686

Related branches

lp:~andrewsomething/sphinx/lp480913
Merged into lp:ubuntu/precise/sphinx at revision 30
Daniel Holbach: Approve on 2012-03-16
Ubuntu branches: Pending requested 2012-03-15
David Fokkema (dfokkema) wrote :
Changed in sphinx (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium

This is because sphinx is in main, and .mo file are stripped out put in language-pack-* packages. As a work-a-round for building locally, make sure you have the desired one installed. The original reporter's case that is language-pack-nl-base.

This causes a problem for any package that build depends on sphinx trying to build documentation in multiple locales. We're hitting this with the Ubuntu Packaging Guide. See bug 943154.

David Planella seems to think that we might be able to get sphinx excluded from the .mo file stripping and suggests talking to pitti.

Martin Pitt (pitti) wrote :

I advise to set "export NO_PKG_MANGLE=1" in debian/rules to keep the .mo files.

Changed in sphinx (Ubuntu):
status: Confirmed → Triaged
Changed in sphinx (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sphinx - 1.1.2+dfsg-4ubuntu3

---------------
sphinx (1.1.2+dfsg-4ubuntu3) precise; urgency=low

  * debian/rules: export NO_PKG_MANGLE=1 in order to
    not have translations stripped (LP: #480913).
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 13 Mar 2012 12:34:01 -0400

Changed in sphinx (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers