upload speed is reported wrong

Bug #1828929 reported by Redstorm on 2019-05-14
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
speedtest-cli (Ubuntu)
Undecided
Unassigned
Bionic
Medium
Unassigned

Bug Description

speedtest-cli version 2.0.0 installed from repo miss reports upload speed.

Upload speed is capped at 4.12Mbit/s but link is capable of 430Mbit/s, dose not matter which server you use to test against its always capped at 4.12Mbit/s upload

Tested using 2.1.1 and got 166Mbits/s upload. Windows PC on same network got 430Mbit/s upload

2.0.0
speedtest-cli --server 5539
Retrieving speedtest.net configuration...
Testing from 2degrees Broadband (203.86.204.88)...
Retrieving speedtest.net server list...
Retrieving information for the selected server...
Hosted by 2degrees (Auckland) [1.37 km]: 3.033 ms
Testing download speed................................................................................
Download: 892.48 Mbit/s
Testing upload speed......................................................................................................
Upload: 4.13 Mbit/s

2.1.1
./speedtest.py --server 5539
Retrieving speedtest.net configuration...
Testing from 2degrees Broadband (203.86.204.88)...
Retrieving speedtest.net server list...
Retrieving information for the selected server...
Hosted by 2degrees (Auckland) [1.37 km]: 3.069 ms
Testing download speed................................................................................
Download: 880.28 Mbit/s
Testing upload speed................................................................................................
Upload: 166.86 Mbit/s

https://www.speedtest.net/result/8256366032

Description: Ubuntu 18.04.2 LTS
Release: 18.04

speedtest-cli:
  Installed: 2.0.0-1
  Candidate: 2.0.0-1
  Version table:
 *** 2.0.0-1 500
        500 http://us1.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://us1.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status

Expect the upload speed to be reported correctly.

Redstorm (spencer-roff) wrote :

./speedtest.py --server 5539
Retrieving speedtest.net configuration...
Testing from 2degrees Broadband (203.86.204.88)...
Retrieving speedtest.net server list...
Retrieving information for the selected server...
Hosted by 2degrees (Auckland) [1.37 km]: 3.011 ms
Testing download speed................................................................................
Download: 890.97 Mbit/s
Testing upload speed................................................................................................
Upload: 302.73 Mbit/s

Another run with 302 using version 2.1.1 of the python script.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in speedtest-cli (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) on 2019-08-22
tags: added: bionic
Ben (bcannon) wrote :

Just wanted to mention that I see this across multiple hardware platforms, Ubuntu 18.04 LTS

Ethan Matten (ethanm22) wrote :

nothing to do with hardware in any way, it was an issue with the script and was fixed a while ago, but the publisher didn't make it available for older versions

hackeron (hackeron) wrote :

I've got the same issue :( - any solution?

Hendrik Brinkmann (henok321) wrote :

I have solved the problem by installing speedtest-cli via pip (python package manager) instead of apt. The pip package contains the bugfix.

https://pypi.org/project/speedtest-cli/

Matthew Brantley (mbrantley) wrote :

When running speedtest-cli on python 2.7 installed via apt I was seeing:

Upload: 3.91 Mbit/s

I removed the package, installed python & pip, installed speedtest-cli via pip and received:

Upload: 43.27 Mbit/s

Thank you for the workaround!

I ran git bisect against upstream and identified the patch fixes this bug - it is https://github.com/sivel/speedtest-cli/commit/a8a32650015997f7847f2de72a29ff7906f53d8a

It is tiny and applies cleanly against Ubuntu's 2.0.0-1 package, hopefully it is acceptable to merge?

Forgot to mention, I confirmed the patch does resolve the issue:

# speedtest-cli --no-download
Retrieving speedtest.net configuration...
Testing from Mammoth Media Pty (103.1.186.209)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Telstra (Chatswood) [6.11 km]: 1.056 ms
Skipping download test
Testing upload speed......................................................................................................
Upload: 1.67 Mbit/s

# patch /usr/lib/python3/dist-packages/speedtest.py speedtest.patch
patching file /usr/lib/python3/dist-packages/speedtest.py
Hunk #1 succeeded at 1474 (offset -48 lines).

# speedtest-cli --no-download
Retrieving speedtest.net configuration...
Testing from Mammoth Media Pty (103.1.186.209)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Telstra (Chatswood) [6.11 km]: 1.093 ms
Skipping download test
Testing upload speed......................................................................................................
Upload: 931.40 Mbit/s

The attachment "Patch for /usr/lib/python3/dist-packages/speedtest.py" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in speedtest-cli (Ubuntu):
status: Confirmed → Fix Released
Changed in speedtest-cli (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium

I'm unclear why this has been marked as "Fix Released"? The bionic package has not been updated.

Yury (aero) wrote :

I confirm.
Issue still exist.

Marc Michele (easyone) wrote :

Problem still exist. Cost me some time to figure out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers