spectral-cube fails to build in 16.04 LTS

Bug #1598145 reported by Matthias Klose on 2016-07-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
spectral-cube (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

backport of the upload in yakkety is needed

 fakeroot debian/rules clean
dh clean --with python2,python3 --buildsystem=pybuild
   dh_testdir -O--buildsystem=pybuild
   dh_auto_clean -O--buildsystem=pybuild
I: pybuild base:184: python2.7 setup.py clean
/usr/lib/python2.7/dist-packages/astropy_helpers/setup_helpers.py:102: AstropyDeprecationWarning: Direct use of the adjust_compiler function in setup.py is deprecated and can be removed from your setup.py. This functionality is now incorporated directly into the build_ext command.
  'command.', AstropyDeprecationWarning)
running clean
removing '/«PKGBUILDDIR»/.pybuild/pythonX.Y_2.7/build' (and everything under it)
'build/bdist.linux-x86_64' does not exist -- can't clean it
'build/scripts-2.7' does not exist -- can't clean it
I: pybuild base:184: python3.5 setup.py clean
Traceback (most recent call last):
  File "setup.py", line 25, in <module>
    conf = config.ConfigParser()
AttributeError: module 'distutils.config' has no attribute 'ConfigParser'
E: pybuild pybuild:274: clean: plugin distutils failed with: exit code=1: python3.5 setup.py clean
dh_auto_clean: pybuild --clean --test-pytest -i python{version} -p 3.5 --dir . returned exit code 13
debian/rules:10: recipe for target 'clean' failed
make: *** [clean] Error 25

Hello Matthias, or anyone else affected,

Accepted spectral-cube into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/spectral-cube/0.3.1-4~16.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in spectral-cube (Ubuntu):
status: New → Fix Released
Changed in spectral-cube (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Matthias Klose (doko) wrote :

package built successfully.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package spectral-cube - 0.3.1-4~16.04

---------------
spectral-cube (0.3.1-4~16.04) xenial-proposed; urgency=medium

  * SRU: LP: #1598145. Fix build failure.

spectral-cube (0.3.1-4) unstable; urgency=medium

  * Use LooseVersion instead of StrictVersion. Closes: #825900

spectral-cube (0.3.1-3) unstable; urgency=medium

  * Add d/upstream/metadata
  * Correct Vcs-Git URL
  * Use ConfigParser module instead of the one embedded in
    distutils.config. Closes: 825817
  * Update Standards-Version to 3.9.8. No changes needed

 -- Matthias Klose <email address hidden> Fri, 01 Jul 2016 14:44:08 +0200

Changed in spectral-cube (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for spectral-cube has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers