kiki should depend on python-wxgtk2.6 or python-wxgtk2.8, not just on python-wxgtk2.6

Bug #370839 reported by TiKaey on 2009-05-02
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kiki (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Emilio Pozuelo Monfort
spe (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Emilio Pozuelo Monfort

Bug Description

SRU request (can be started after patch is released for Karmic):

1) Kiki (depends on python-wxgtk2.6) is mostly installed as a dependency of SPE (depends on python-wxgtk2.8). This causes three issues:

1.a This will install unnecessarily two version of python-wxgtk.

1.b This might break any wxpython application which depends on python-wxgtk2.8 and only uses "import wx" instead of wxversion (see the original bug report). It breaks because since Jaunty python-wxgtk2.6 is the default when 2.6 and 2.8 or both installed (because of a packaging error in wxwidgets, see bug #379573).

1.c Another problem with kiki is that it was developed for python-wxgtk2.4, which uses a class (wx.NotebookSizer) which is deprecated in python-wxgtk2.6 and unavailable in python-wxgtk2.8. This causes that a serious deprecation warning in python-wxgtk2.6 is displayed and that kiki is incompatible with python-wxgtk2.8

2) Therefore I (stani) propose a fix, which changes three lines:
2.a kiki.py: it let kiki use both python-wxgtk2.6 and python-wxgtk2.8
2.b kiki.py: it removes the deprecated class (wx.NotebookSizer) of python-wxgtk2.4
2.c debian/control: it changes the dependency to python-wxgtk2.8 or python-wxgtk2.8, instead of only python-wxgtk2.6
This fix has been already prepared for the current development branch (karmic). Version prepared is 0.5.6-3.1ubuntu2 and the debdiff used can be found at this link:
http://launchpadlibrarian.net/27099210/kiki_0.5.6-3.1ubuntu2.debdiff

3) A debdiff (0.5.6-3.1ubuntu1.9.04) for jaunty-proposed has been already prepared and can be found at
http://launchpadlibrarian.net/27099231/kiki_0.5.6-3.1ubuntu1.9.04.debdiff

4) TEST CASE: to reproduce the bug, just follow this small steps:

4.a install spe (which will install kiki): sudo apt-get install spe

4.b you'll notice that both python-wxgtk2.8 and python-wxgtk2.6 get installed, while python-wxgtk2.8 should be enough

4.c start python and see that wxpython2.6 is used (instead of python-wxgtk2.8):
>>> import wx
>>> wx.VERSION
(2, 6, 3, 2, '')
So most wxPython applications now expect 2.8, see the original bug report.

4.d run kiki to see the deprecation warning:
$ kiki
/usr/lib/python2.6/dist-packages/kiki/kiki.py:320: DeprecationWarning: NotebookSizer is no longer needed.
  TopPaneSizer.Add(wx.NotebookSizer(self.Notebook), 1, wx.EXPAND, 0)

Original bug report:

Binary package hint: spe

Ubuntu 9.04 - Jaunty Jackalope

Since Jaunty the dependencies from SPE are python-wx2.6 AND python-wx2.8 i've got errors in my wxPython-apps with wx.StaticText argument 'Label', that don't comes, when only python-wx2.8 is installed.
Also running python-apps in SPE work not correctly.
In Intrepid these bugs are not there.

Removed python-wx2.6 and kiki with dpkg, then my apps an SPE are running correctly.
But Synaptik wants to update/reinstall them.

So it make sense, to remove dependencies on SPE with python-wx2.6.

Stani (stani) wrote :

The dependencies on python-wxgtk2.6 can indeed dissappear. There is no reason why kiki should depend on 2.6 This was because for a long time debian didn't support 2.8 Now this issue is over since Lenny. So I'll try to bump the dependency of kiki to 2.8

Changed in spe (Ubuntu):
assignee: nobody → stani (stani)
status: New → In Progress
summary: - dependencies of SPE create errors in wxPython-apps and in SPE too
+ dependencies of SPE on python-wxgtk2.6 create errors in wxPython-apps
+ and in SPE too

There's an OR depend between 2.6 an 2.8 versions, this issue is due to kiki dependencies (spe depends on it), which depends only on python-wxgtk2.6

Stani (stani) wrote :

@Alessio:
I know that is why I will add this OR dependency as well to kiki. Kiki should run fine with 2.6, if not I'll fix it.

Stani (stani) on 2009-05-23
summary: - dependencies of SPE on python-wxgtk2.6 create errors in wxPython-apps
- and in SPE too
+ kiki should depend on python-wxgtk2.6 or python-wxgtk2.8, not just on
+ python-wxgtk2.6
Changed in kiki (Ubuntu):
assignee: nobody → stani (stani)
status: New → In Progress
Stani (stani) wrote :

This a debdiff patch for Karmic.

Stani (stani) wrote :

This is a debdiff patch for Jaunty.

Changed in kiki (Ubuntu):
assignee: stani (stani) → nobody
status: In Progress → Confirmed
Changed in spe (Ubuntu):
assignee: stani (stani) → nobody
status: In Progress → Confirmed
Stani (stani) wrote :

BTW my fixes also solve the Deprecation warning when running kiki with python-wxgtk2.6:

$ kiki
/usr/lib/python2.6/dist-packages/kiki/kiki.py:320: DeprecationWarning: NotebookSizer is no longer needed.
  TopPaneSizer.Add(wx.NotebookSizer(self.Notebook), 1, wx.EXPAND, 0)

Durand D'souza (durand1) wrote :

Thanks for fixing the bug!

Stefan Lesicnik (stefanlsd) wrote :

Patches look good and sane.

For the Jaunty SRU - follow the procedures outlined here

https://wiki.ubuntu.com/StableReleaseUpdates

Stani (stani) on 2009-06-05
description: updated
Stefan Lesicnik (stefanlsd) wrote :

Hey Stani.

Can you check a few things.

1. The debdiff for karmic (possibly the other also) has ctrl-m characters (^M). Removing them causes the patch to fail. Could you have a look at that and re-upload the diff.

2. (Closes LP: #370839) is a mix of Debian and Ubuntu. Just use (LP: #)

3. The SRU debdiff should be for jaunty-proposed and not just Jaunty.

I'll upload the Karmic fix as soon as these got sorted.

Thanks for your time with this.

Changed in kiki (Ubuntu):
status: Confirmed → Incomplete
Ignace Mouzannar (ghantoos) wrote :

Hi,

The Debian package now depends exclusively on python-wxgtk2.8. A new patch has been applied [1] to migrate it to wxwidgets2.8.
----
~$ apt-cache --no-all-versions show kiki | grep Depends
Depends: python2.7 | python2.6, python (>= 2.6.6-7~), python (<< 2.8), python-wxgtk2.8
----

I hadn't seen this bug report before, or else I would have added the LP field closing this bug. I will request a sync from Debian.

Regards,
 Ignace M

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=645755

no longer affects: spe (Ubuntu Jaunty)
no longer affects: kiki (Ubuntu Jaunty)
Ignace Mouzannar (ghantoos) wrote :

This bug has been fixed in the following upload [1].

Cheers,
 Ignace M

[1] https://bugs.launchpad.net/ubuntu/+source/kiki/+bug/894817

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.