spca5xx/khubd uses 100% cpu and unable to reboot/halt

Bug #32164 reported by Cristian Aravena Romero on 2006-02-20
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
spca5xx (Ubuntu)
Medium
Unassigned

Bug Description

Subject: spca5xx/khubd uses 100% cpu and unable to reboot/halt

Package: ekiga
Version: 1.99.1-0ubuntu2
Severity: important

Information:
* Run ekiga
* Configure all (With wizardconf)
 [...]
 * Use Video V4l (detect correct usb camera, test ok!)
 [...]
* Close windows (Open in icontray)

Problem:
* Unplugged usb video camera (not close icontray of ekiga)
* Process khubd use cpu to ~99% (test in 4 minutes)

Solution Temp:
* Open console
* $ps -ef | grep khubd
* $kill NumberProcess_khub
* In 2 minutes ++, $kill -9 numerProcess_khub
* Add 2 minutes, $sudo killall -9 khubd
* Add 2 minutes, reviste top: khubd use 97~99% cpu (caravena sleeping and khubd run)

Solution Temp 2, Rebbot!!:
* $sudo reboot
[Services stop [OK]...]

Shutting down Alsa [OK]
Bluetooth services ... (caravena sleeping2 and notebook not rebook)

* Not stop Bluetooth service and not rebook.

Info:
[1] https://wiki.ubuntu.com/LaptopTestingTeam/CompaqPresarioV2417LA

-- System Information:
Ubuntu Release: testing/unstable/Dapper Flight 4
  APT prefers dapper
  APT policy: (500, 'dapper')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-15-k7
Locale: LANG=es_CL.UTF-8, LC_CTYPE=es_CL.UTF-8 (charmap=UTF-8)

Versions of packages ekiga depends on:
ii evolution-data-server 1.5.91-0ubuntu2 evolution database backend server
ii gconf2 2.13.5-0ubuntu1 GNOME configuration database syste
ii libart-2.0-2 2.3.17-1 Library of functions for 2D graphi
ii libatk1.0-0 1.11.2-0ubuntu1 The ATK accessibility toolkit
ii libaudiofile0 0.2.6-6 Open-source version of SGI's audio
ii libavahi-client3 0.6.7-1ubuntu1 Avahi client library
ii libavahi-common3 0.6.7-1ubuntu1 Avahi common library
ii libavahi-glib1 0.6.7-1ubuntu1 Avahi glib integration library
ii libbonobo2-0 2.13.1-0ubuntu2 Bonobo CORBA interfaces library
ii libbonoboui2-0 2.13.1-0ubuntu1 The Bonobo UI library
ii libc6 2.3.6-0ubuntu6 GNU C Library: Shared libraries an
ii libcairo2 1.0.2-3ubuntu1 The Cairo 2D vector graphics libra
ii libebook1.2-5 1.5.91-0ubuntu2 Client library for evolution addre
ii libedataserver1.2-7 1.5.91-0ubuntu2 Utility library for evolution data
ii libesd-alsa0 [libesd0 0.2.36-3ubuntu2 Enlightened Sound Daemon (ALSA) -
ii libfontconfig1 2.3.2-1.1ubuntu3 generic font configuration library
ii libgcc1 1:4.0.2-9ubuntu1 GCC support library
ii libgconf2-4 2.13.5-0ubuntu1 GNOME configuration database syste
ii libglib2.0-0 2.9.6-0ubuntu1 The GLib library of C routines
ii libgnome-keyring0 0.4.7-0ubuntu1 GNOME keyring services library
ii libgnome2-0 2.13.7-0ubuntu2 The GNOME 2 library - runtime file
ii libgnomecanvas2-0 2.13.0-0ubuntu1 A powerful object-oriented display
ii libgnomeui-0 2.13.3-0ubuntu1 The GNOME 2 libraries (User Interf
ii libgnomevfs2-0 2.13.91-0ubuntu1 The GNOME virtual file-system libr
ii libgtk2.0-0 2.8.11-1ubuntu2 The GTK+ graphical user interface
ii libice6 2:1.0.0-0ubuntu2 X11 Inter-Client Exchange library
ii liblaunchpad-integrat 0.1.2 library for launchpad integration
ii libopal-2.2.0 2.1.3-0ubuntu3 Open Phone Abstraction Library - s
ii liborbit2 1:2.13.3-0ubuntu1 libraries for ORBit2 - a CORBA ORB
ii libpango1.0-0 1.11.5-0ubuntu1 Layout and rendering of internatio
ii libpopt0 1.7-5 lib for parsing cmdline parameters
ii libpt-1.10.0 1.9.3-0ubuntu1 Portable Windows Library
ii libpt-plugins-alsa 1.9.3-0ubuntu1 Portable Windows Library Audio Plu
ii libpt-plugins-v4l 1.9.3-0ubuntu1 Portable Windows Library Video Plu
ii libpt-plugins-v4l2 1.9.3-0ubuntu1 Portable Windows Library Video Plu
ii libsdl1.2debian 1.2.9-0.0ubuntu1 Simple DirectMedia Layer
ii libsm6 2:1.0.0-0ubuntu2 X11 Session Management library
ii libstdc++6 4.0.2-9ubuntu1 The GNU Standard C++ Library v3
ii libx11-6 2:1.0.0-0ubuntu3 X11 client-side library
ii libxcursor1 1.1.5.2-0ubuntu2 X cursor management library
ii libxext6 2:1.0.0-0ubuntu3 X11 miscellaneous extension librar
ii libxfixes3 1:3.0.1.2-0ubuntu2 X11 miscellaneous 'fixes' extensio
ii libxi6 2:1.0.0-0ubuntu2 X11 Input extension library
ii libxinerama1 2:1.0.1-0ubuntu2 X11 Xinerama extension library
ii libxml2 2.6.23-1ubuntu4 GNOME XML library
ii libxrandr2 1:1.1.0.2-0ubuntu2 X11 RandR extension library
ii libxrender1 1:0.9.0.2-0ubuntu2 X Rendering Extension client libra
ii zlib1g 1:1.2.3-6ubuntu4 compression library - runtime

Versions of packages ekiga recommends:
ii libpt-plugins-alsa 1.9.3-0ubuntu1 Portable Windows Library Audio Plu
pn libpt-plugins-avc <none> (no description available)
pn libpt-plugins-dc <none> (no description available)
pn libpt-plugins-oss <none> (no description available)
ii libpt-plugins-v4l 1.9.3-0ubuntu1 Portable Windows Library Video Plu
ii libpt-plugins-v4l2 1.9.3-0ubuntu1 Portable Windows Library Video Plu

-- no debconf information

I see something similar, with the spca5xx webcam module.

Sometimes after launching ekiga, it can't find the video device, although it worked earlier. It seems if I then quit ekiga and unplug the camera, khubd uses >90% CPU.

dmesg at this point says:

[4299289.491000] usb 1-1: USB disconnect, address 2
[4299289.492000] drivers/usb/media/spca5xx/spca5xx-main.c: usb_submit_urb() ret -19
[4299289.492000] drivers/usb/media/spca5xx/spca5xx-main.c: usb_submit_urb() ret -19

I'm not entirely sure I reproduced it yet, will continue trying. Please tell me if I shall test for something specific.

Daniel Holbach (dholbach) wrote :

Hello Kernel Team - any idea, how to debug this?

Changed in ekiga:
assignee: nobody → ubuntu-kernel-team
Mario Vukelic (mario-vukelic) wrote :

First, I am on up-to-date dapper, kernel 2.6.15-19-686

Further debugging shows that the USB plugin sequence does not matter for me, I get the problem in either case.

I did:
reboot, plug in cam, start ekiga, open window, check video - works, close window but let ekiga run in panel, unplug cam
-> khubd goes wild.

Ekiga does not seem to react on rightclicking it in the notification area -> quit, but sending a kill -TERM to ekiga shuts it down and then khubd returns to normal

In either case, dmesg is:
[4294858.997000] usb 1-2: new full speed USB device using uhci_hcd and address 2
[4294859.316000] Linux video capture interface: v1.00
[4294859.372000] drivers/usb/media/spca5xx/spca5xx-main.c: USB SPCA5XX camera found. Type Creative Webcam Notebook Zc301+Tas5130c
[4294859.610000] usbcore: registered new driver spca5xx
[4294859.610000] drivers/usb/media/spca5xx/spca5xx-main.c: spca5xx driver 00.57.08 registered
[4294896.544000] usb 1-2: USB disconnect, address 2
[4294896.545000] drivers/usb/media/spca5xx/spca5xx-main.c: usb_submit_urb() ret -19
[4294896.545000] drivers/usb/media/spca5xx/spca5xx-main.c: usb_submit_urb() ret -19

I removed the module and modprobed it again with "modprobe spca5xx debug=4", but this does not give more messages.

Daniel Holbach (dholbach) wrote :

I suppose this is some kernel breakage as in some other spca5xx bugs:

https://launchpad.net/distros/ubuntu/+bugs?field.searchtext=spca5xx&orderby=-datecreated&search=Search

Alex (gsasha) wrote :

Same happens to me. Parameters:

Version: latest dapper as of today's update
Webcam: Logitech USB Quickcam
Machine: Dell Inspiron 9400

Wesley Stessens (wesley) wrote :

Same happens to me on Dapper Drake 6.06.1 ...
Using spca5xx too, webcam is a "Genius VideoCAM Express"

When I plug in the cam, and I use a webcam program (amsn in my case), and I stop the webcam transfer in amsn, and I plug the webcam out, everything hangs for a second or 2 (music etc. stops for 2 seconds too) and then khubd starts to eat up 99% CPU

Everything is still running smooth enough to be workable (thank god for linux' multitasking capabilities), but the CPU fan is constantly on, and obviously, some big programs react slow now...

When I plug out other USB devices, and I plug them back in, they don't work anymore!!! (my Logitech G5 USB mouse for example)

Wesley Stessens (wesley) wrote :

I'm almost sure that the bug is related to spca5xx, and it also happens with other webcam programs, not just Ekiga

I would also raise importance, because 99% cpu usage is not fun to work with, and other USB devices can't connect/reconnect anymore! Killing the khubd process won't work either!

Changed in ekiga:
status: Unconfirmed → Confirmed
description: updated
Jerome Lacoste (jerome-lacoste) wrote :

1- for those who don't manage to solve the CPU issue, make sure your client is correctly closed (e.g. using 'killall ekiga').

2- I reported this problem to the kernel mailing list, and they told me the problem was in the driver. http://lkml.org/lkml/2007/1/16/41

I then talked to the author who says that the problem is likely to be in the client application. See issue #79539

I asked him to look at and comment these issues.

Alexander Jones (alex-weej) wrote :

Eeee, I just got this right now. Exactly the same. Running Ekiga, then unplug a webcam.

Happens to me too on Debian with gspca, so this isn't Ubuntu-specific.

Simon Hepburn (sth) wrote :

Suspend & Resume with ekiga running and webcam attached triggers this for me.

ekiga 2.03
kernel 2.6.20-16-generic
Logitech Communicate STX with gspca module
Machine is compaq evo D510 desktop

I am now running with my keyboard and mouse connected via ps/2 (with adapters) and I can kill ekiga and then khubd recovers. With USB input it was impossible to do anything other than a hard reboot with the power switch.

olive (olivier.fraysse) wrote :

same bug with camorama.

Marc Carson (baggageclaim) wrote :

Same bug here, camorama plus logitech quickcam im plus

Tyrael (marco-crociani) wrote :

Same bug with motion and 093a:2468 Pixart Imaging, Inc. Easy Snap Snake Eye WebCam, on Hardy.

joecarter (joe-carter) wrote :

I also have this problem on Hardy except that I can kill off the client process via "kill -9".
Client: motion 3.2.9.
Camera: Logitech QuickCam Communicate STX for Skype Bus 005 Device 011: ID 046d:08d7 Logitech, Inc.
USB Hub: Bus 005 Device 007: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
uname -a: 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

I get the problem every time I activate motion with this web cam.

mattcasters (matt-casters) wrote :

Something must have gone wrong with one of the latest Hardy kernel updates.
I'm seeing the khubd go 100% as well on my Logitech Quickcam (it worked just fine before).
Also USB related: after suspend mouse and other USB devices fail to get detected. Workarounds as suggested on forums do not work. Suspend worked flawlessly before on my Dell Precision M60 laptop. (Core 2 Duo 2.33Ghz, 3.3GB RAM)
Usually a reboot is the only thing I can do to fix my box, including in the case of this bug.

uname -a: Linux Hannelore 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux

hazylazysusan (hazylazysusan) wrote :

I have a problem in Intrepid with gspca whereby khubd is unkillable without a reboot when I plug out and then plug in the cam again

Usufruct (benlong) wrote :

I also discovered this bug in intrepid. Unplugged my camera while a flash-based camera webpage was loaded, and khubd spiked to 100% only on my second CPU. Kill did not work, kill -15 did not work, and kill -9 did not work.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers