unable to import soya due to undefined symbol

Bug #780305 reported by Jeffrey Finkelstein
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
soya (Debian)
Fix Released
Unknown
soya (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Run python2.7 on Ubuntu 11.04, try to import soya and you get the following backtrace:

Python 2.7.1+ (r271:86832, Apr 11 2011, 18:05:24)
[GCC 4.5.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import soya
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/pymodules/python2.7/soya/__init__.py", line 28, in <module>
    from soya._soya import *
ImportError: /usr/lib/pymodules/python2.7/soya/_soya.so: undefined symbol: gluTessVertex

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: python-soya 0.15~rc1-3build1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Tue May 10 00:55:43 2011
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: soya
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Jeffrey Finkelstein (jfinkels) wrote :
Revision history for this message
Julian Taylor (jtaylor) wrote :

attached patch fixes the issue by explicitly linking against libGLU.
It seems to be caused by the new toolchain but debian is not affected even with --as-needed and --no-add-needed.

tags: added: patch
Revision history for this message
Julian Taylor (jtaylor) wrote :

the reason is probably that libGLEW is not linked against libGLU in natty.
Forwarded upstream.
http://gna.org/bugs/index.php?18131

Changed in soya (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package soya - 0.15~rc1-3ubuntu1

---------------
soya (0.15~rc1-3ubuntu1) oneiric; urgency=low

  * debian/patches/link-with-gl-and-glu.patch:
    link soya against gl and glu which it uses directly (LP: #780305)
 -- Julian Taylor <email address hidden> Mon, 18 Jul 2011 01:00:54 +0200

Changed in soya (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Michael Terry (mterry) wrote :

I've uploaded a fix to natty-proposed and subscribed ubuntu-sru for this regression. Please test and report back.

Changed in soya (Ubuntu Natty):
status: New → Triaged
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Jeffrey, or anyone else affected,

Accepted soya into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in soya (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in soya (Debian):
status: Unknown → Fix Released
Revision history for this message
Jeffrey Finkelstein (jfinkels) wrote :

This is fixed with the package from natty-proposed.

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package soya - 0.15~rc1-3ubuntu0.1

---------------
soya (0.15~rc1-3ubuntu0.1) natty-proposed; urgency=low

  * debian/patches/link-with-gl-and-glu.patch:
    link soya against gl and glu which it uses directly (LP: #780305)
 -- Julian Taylor <email address hidden> Mon, 18 Jul 2011 01:00:54 +0200

Changed in soya (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.