banshee crashes on oneiric

Bug #824505 reported by GodNobody on 2011-08-11
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
soundtouch (Debian)
Fix Released
Unknown
soundtouch (Ubuntu)
Undecided
Unassigned

Bug Description

Just tried to run banshee and it crashed...

Terminal output attached

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: banshee 2.1.0-1ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Thu Aug 11 14:49:32 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110731)
SourcePackage: banshee
UpgradeStatus: Upgraded to oneiric on 2011-08-09 (1 days ago)

GodNobody (godnobody) wrote :
Chow Loong Jin (hyperair) wrote :

The problem was found in Debian's soundtouch 1.6.0-1. Downgrading the libsoundtouch0 package should do the trick. Alternatively, move /usr/lib/banshee/Extensions/Banshee.Bpm.dll somewhere else, to prevent Banshee from attempting BPM detection (which uses libsoundtouch0).

affects: banshee (Ubuntu) → soundtouch (Ubuntu)
Changed in soundtouch (Debian):
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in soundtouch (Ubuntu):
status: New → Confirmed
Peter Hawkins (hawkinsp) wrote :

I confirm this bug. Banshee crashes on startup on oneiric; if I move the Banshee.Bpm.dll library away Banshee starts fine.

zmago (zmago-fluks) wrote :

It's easy workaround to move Banshee.Bpm.dll out of folder. But if Ubuntu wants to be user friendly then this workaround is frustrating. Yesterday i've installed it and i had to investigate why Banshee is chrashing. Now imagine average user... what he/she would do? Stop using Ubuntu or install some other music player...
 I know that here is not the right place to talk about that but after all this time Ubuntu project should concentrate more on quality instead on new features.

Changed in soundtouch (Debian):
status: Confirmed → Fix Released
Chow Loong Jin (hyperair) wrote :

Closing this bug as the Debian bug was closed -- there's another crasher bug regarding BPM detection in Bug #1193667 which I have the fix for.

Changed in soundtouch (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.