NeroAAC broken?

Bug #765169 reported by Alexey Ivanov on 2011-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
soundkonverter (Ubuntu)
Undecided
Daniel Faust

Bug Description

Binary package hint: soundkonverter

Latest git version with latest neroaac encoder convert to broken AAC files!

Daniel Faust (hessijames) wrote :

Could you please be more specific.
I tried encoding with neroaac 1.5.1 and the .aac file is working. Not with vlc, indeed but it's working fine with mplayer and audacious.

Alexey Ivanov (alexey-ivanov) wrote :

files converted with nero AAC will not play in Linux.

+ in your program when you convert a faac I get a file size of 300kb and the extension of AAC (without container mp4)

Daniel Faust (hessijames) wrote :

i'm sorry, but i don't get the problem.
you really need to provide more details.
please tell me exactly what you tried to do and what happend.
also, does it happen with every file or just with a few?

Alexey Ivanov (alexey-ivanov) wrote :

http://www.youtube.com/watch?v=xjWfVNiVEa4

Look please this little screencast.

In NeroAAC indicated that the bitrate should be in bytes, now soundkonverter says codec 320 bytes not 320000 bytes.
http://wiki.hydrogenaudio.org/index.php?title=Nero_AAC

Output files obtained with the expansion of AAC, it might be worth to wrap them in a container mp4, m4a?

Daniel Faust (hessijames) wrote :

That's much better :)
The bitrate problem is fixed now.
But as you pointed out, the aac and mp4/m4a formats are handled wrong.
This is a little bit more complicated but I'm on it.

Changed in soundkonverter (Ubuntu):
assignee: nobody → HessiJames (hessijames)
status: New → In Progress
Daniel Faust (hessijames) wrote :

As of version 1.0.0 both, the bitrate bug and the handling of aac/m4a/mp4 files is fixed.

Changed in soundkonverter (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers