Bad audio quality when converting from AAC to Vorbis

Bug #508767 reported by Jarno Suni on 2010-01-17
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GStreamer
Invalid
Medium
SoundConverter
Medium
GautierPortet
soundconverter (Ubuntu)
Medium
GautierPortet

Bug Description

Binary package hint: soundconverter

When I convert video http://www.youtube.com/watch?v=hckcdyQad0I (available as a /tmp/Flash*) to Ogg Vorbis, the result is low quality audio file, even if setting for quality is "High". I can hear snapping when playing by some players. For what it is worth, the quality is very low, if I play the file by alsaplayer (0.99.80), by which I have had no problem with other Ogg Vorbis files (as long as filename extension is .ogg).

ProblemType: Bug
Architecture: i386
Date: Sun Jan 17 15:38:22 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Xubuntu 9.10 "Karmic Koala" - Release i386 (20091028.3)
Package: soundconverter 1.4.4-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: soundconverter
Uname: Linux 2.6.31-17-generic i686

Jarno Suni (jarnos) wrote :
GautierPortet (kassoulet) wrote :

I tried to convert the exact same file, and you are right, something is wrong when converting to ogg vorbis.
Every other formats have a correct sound.
I'm going to investigate on this issue, to determine if it's soundconverter fault, or if the problem should be pushed upstream to gstreamer.

GautierPortet (kassoulet) wrote :

Tested with another .flv, same results.
Converting to wav and then to vorbis works as expected.

GautierPortet (kassoulet) wrote :

I can reproduce the problem with gst-launch, so I blame gstreamer ;)

Anyway, the problem disapears if i insert "wavenc ! wavparse" in the pipeline. That is, convert to wav and back.
Something really strange is happening here, and I can't find out why.

GautierPortet (kassoulet) wrote :

It works when converting to wav and flac, and fails converting to vorbis and mp3 BTW.

Charlie Kravetz (charlie-tca) wrote :

I am marking this confirmed; the issue has been reported upstream.

Changed in soundconverter (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in soundconverter (Ubuntu):
status: Confirmed → Triaged
Changed in gstreamer:
importance: Unknown → Medium
status: Unknown → New
Changed in gstreamer:
status: New → Confirmed
psl (slansky) wrote :

Check bug report #792742 related to OGG corruption.

ill (illumilore) wrote :

This bug does not happen in the kde soundkonverter app (which I stopped using around a year and a half ago because it had some bug that caused very similar corruption issues), so that might work as a replacement until this is fixed.

Changed in soundconverter:
assignee: nobody → GautierPortet (kassoulet)
Changed in soundconverter (Ubuntu):
assignee: nobody → GautierPortet (kassoulet)
Changed in soundconverter:
milestone: none → 1.6.0
importance: Undecided → Medium
status: New → Confirmed
Changed in soundconverter:
status: Confirmed → In Progress
Changed in soundconverter:
status: In Progress → Fix Committed
Changed in gstreamer:
status: Confirmed → Invalid
Changed in soundconverter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.