soundconverter crashes on batch everytime

Bug #243831 reported by Brett Alton
4
Affects Status Importance Assigned to Milestone
SoundConverter
Undecided
Unassigned
soundconverter (Ubuntu)
Undecided
William Grant

Bug Description

Binary package hint: soundconverter

No matter how I run soundconverter on the command line, whether I simply run it with '-b' or '-b < $file' ($file can be either seperated by spaces or newlines), soundconverter crashes.

$ soundconverter -b
SoundConverter 1.0.1
  using Gstreamer version: 0.10.18, Python binding version: 0.10.11
  using gnomevfssrc
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 2563, in <module>
    main()
  File "/usr/bin/soundconverter", line 2559, in main
    cli_convert_main(args)
  File "/usr/bin/soundconverter", line 2457, in cli_convert_main
    if previous_filename != t.sound_file.get_filename_for_display():
AttributeError: 'NoneType' object has no attribute 'sound_file'

$ soundconverter -b < m4a-2.txt
SoundConverter 1.0.1
  using Gstreamer version: 0.10.18, Python binding version: 0.10.11
  using gnomevfssrc
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 2563, in <module>
    main()
  File "/usr/bin/soundconverter", line 2559, in main
    cli_convert_main(args)
  File "/usr/bin/soundconverter", line 2457, in cli_convert_main
    if previous_filename != t.sound_file.get_filename_for_display():
AttributeError: 'NoneType' object has no attribute 'sound_file'

$ uname -a && lsb_release -c
Linux laptop 2.6.24-19-generic #1 SMP Wed Jun 18 14:43:41 UTC 2008 i686 GNU/Linux
Codename: hardy

$ cat /proc/cpuinfo | grep 'model name'
model name : Intel(R) Core(TM)2 CPU T5300 @ 1.73GHz
model name : Intel(R) Core(TM)2 CPU T5300 @ 1.73GHz

Revision history for this message
Brett Alton (brett-alton-deactivatedaccount) wrote :

It fails with soundconverter 1.2.0 was well (installed from Intrepid in Hardy):

$ soundconverter -b < Desktop/m4a.txt
SoundConverter 1.2.0
  using Gstreamer version: 0.10.18, Python binding version: 0.10.11
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 2606, in <module>
    main()
  File "/usr/bin/soundconverter", line 2602, in main
    cli_convert_main(args)
  File "/usr/bin/soundconverter", line 2500, in cli_convert_main
    if previous_filename != t.sound_file.get_filename_for_display():
AttributeError: 'NoneType' object has no attribute 'sound_file'

$ soundconverter -b
SoundConverter 1.2.0
  using Gstreamer version: 0.10.18, Python binding version: 0.10.11
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 2606, in <module>
    main()
  File "/usr/bin/soundconverter", line 2602, in main
    cli_convert_main(args)
  File "/usr/bin/soundconverter", line 2500, in cli_convert_main
    if previous_filename != t.sound_file.get_filename_for_display():
AttributeError: 'NoneType' object has no attribute 'sound_file'

Revision history for this message
GautierPortet (kassoulet) wrote :

I don't reproduce in 1.3.1, but I commited a fix in svn anyway since it was a trivial change.

William Grant (wgrant)
Changed in soundconverter:
assignee: nobody → wgrant
status: New → In Progress
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package soundconverter - 1.3.2-0ubuntu1

---------------
soundconverter (1.3.2-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #255869)
    - Fixes crash in batch mode. (LP: #243831)

 -- William Grant <email address hidden> Fri, 08 Aug 2008 08:47:20 +1000

Changed in soundconverter:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers