Unable to convert any music using soundconverter

Bug #1614466 reported by Rey Leonard Amorato on 2016-08-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Critical
GautierPortet
soundconverter (Ubuntu)
Undecided
GautierPortet

Bug Description

I used to be able to convert music using Ubuntu 15.10, now with 16.04 the program just hangs when pressing convert button.

Output from soundconverter --debug:

SoundConverter 2.9.0-beta1
  using GTK version: 3.0
  using Gstreamer version: 1.8.2.0
  using 8 thread(s)
  using gio
  "faac" gstreamer element not found, disabling AAC output.
/usr/share/soundconverter/python/soundconverter/ui.py:1456: Warning: g_value_type_transformable: assertion 'G_TYPE_IS_VALUE (src_type)' failed
  builder.add_from_file(gladefile)

(python3:4218): Gtk-WARNING **: /build/gtk+3.0-6ZPWga/gtk+3.0-3.18.9/./gtk/gtkliststore.c:836: Unable to convert from (null) to gchararray

Queue start: 1 tasks, 8 thread(s).
launching: 'giosrc location="file:///home/workstation-2/Music/Remote/The%20Killers/Battle%20Born%20%5BDeluxe%20Edition%5D/The%20Killers%20-%20Battle%20Born%20%5BDeluxe%20Edition%5D%20-%2001%20-%20Flesh%20And%20Bone.mp3" ! typefind name=typefinder ! fakesink'
have_type: application/x-id3 The Killers - Battle Born [Deluxe Edition] - 01 - Flesh And Bone.mp3
found_type The%20Killers%20-%20Battle%20Born%20%5BDeluxe%20Edition%5D%20-%2001%20-%20Flesh%20And%20Bone.mp3
Queue done in 0.024s (1 tasks)
Traceback (most recent call last):
  File "/usr/share/soundconverter/python/soundconverter/ui.py", line 1322, in on_convert_button_clicked
    self.do_convert()
  File "/usr/share/soundconverter/python/soundconverter/ui.py", line 1304, in do_convert
    self.converter.add(sound_file)
  File "/usr/share/soundconverter/python/soundconverter/gstreamer.py", line 692, in add
    c.init()
  File "/usr/share/soundconverter/python/soundconverter/gstreamer.py", line 531, in init
    log('Creating folder: \'%s\'' % beautify_uri(dirname))
  File "/usr/share/soundconverter/python/soundconverter/fileoperations.py", line 35, in beautify_uri
    return unquote_filename(uri).split('file://')[-1]
  File "/usr/share/soundconverter/python/soundconverter/fileoperations.py", line 31, in unquote_filename
    return urllib.parse.unquote(filename)
  File "/usr/lib/python3.5/urllib/parse.py", line 537, in unquote
    if '%' not in string:
TypeError: argument of type 'GLocalFile' is not iterable

Linux AAPC-2 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

GautierPortet (kassoulet) wrote :

This is due to a missing error case when the destination folder doesn't exist.

Try with another destination folder, should work fine.

Changed in soundconverter (Ubuntu):
status: New → Confirmed
assignee: nobody → GautierPortet (kassoulet)
Changed in soundconverter:
status: New → Confirmed
assignee: nobody → GautierPortet (kassoulet)
importance: Undecided → Critical
GautierPortet (kassoulet) wrote :
Changed in soundconverter:
status: Confirmed → Fix Committed

Workaround works. Thanks.

Oh, and you mentioned me on the Github page, You're very welcome. Thank you for a great program.

  "faac" gstreamer element not found, disabling AAC output.

It seems there's more to it - even with codecs (Gst bad) installed it seems Soundconverter isn't seeing it.

Fixes attempted include purging and reinstalling them in different orders. It looks like an old/recurring theme. The most common error is folks trying to install 'faac' application, but it's actually covered already and simply not accessed by Soundconverter.

Changed in soundconverter (Ubuntu):
status: Confirmed → Fix Released
Changed in soundconverter:
milestone: none → 3.0.0-beta1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers