[SRU] Python (v2.7) requires to install plugins to play media files of the following typ

Bug #1308187 reported by Thibaut Brandscheid on 2014-04-15
70
This bug affects 18 people
Affects Status Importance Assigned to Milestone
SoundConverter
High
GautierPortet
soundconverter (Ubuntu)
High
GautierPortet
Trusty
High
Unassigned

Bug Description

[SRU] See bug #1423709 for details of this bug fix and the other included.

---

OS: Ubuntu GNOME 14.04 64-Bit
SoundConverter: 2.0.4

I would like to convert a video to an audio file, but when starting the converting process a window appears with the following error message:
Python (v2.7) requires to install plugins to play media files of the following type:
H.264

After clicking on the close button of the error message there is a new 0 bytes sized file in Nautilus, with the name of the video file and the selected audio format file ending.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: soundconverter 2.0.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Apr 15 20:16:10 2014
InstallationDate: Installed on 2014-02-08 (66 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20140206)
PackageArchitecture: all
SourcePackage: soundconverter
UpgradeStatus: No upgrade log present (probably fresh install)

GautierPortet (kassoulet) wrote :

Try to play the video in Totem first, so all required codecs are installed.

Changed in soundconverter (Ubuntu):
assignee: nobody → GautierPortet (kassoulet)

Totem plays the file, there is no problem or you-need-to-install-this-codec window.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in soundconverter (Ubuntu):
status: New → Confirmed
sideshow (nilopolitano) wrote :

+1

same issue.

$ LANG=C apt-cache depends soundconverter
soundconverter
  Depends: python
  Depends: python-gnome2
  Depends: python-glade2
  Depends: python-gst0.10
  Depends: gstreamer0.10-plugins-good
  Depends: gstreamer0.10-plugins-base
  Suggests: gstreamer0.10-plugins-ugly
  Suggests: <gstreamer0.10-ffmpeg>

There is no gstreamer0.10-ffmpeg package.

Andrei Levin (andrei-levin) wrote :

+1
Python 2.7 requires plugin of the type: Decoder H.264

Allan (browwwsers) wrote :

Hello All,

I have the same error usin
AMD A6 5400 if that is of any help.

Qassem Alomari (alomari-qasem) wrote :

just press CTRL+ALT+T
and type :
sudo apt-get update
sudo apt-get install ubuntu-restricted-extras

Hi!

I have the same problem even after I have ran:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras

Do I have to do some configuration after installing ubuntu-restricted-extras?

Thanks!

Krister (thekswenson) wrote :

=> sudo apt-get install ubuntu-restricted-extras
Reading package lists... Done
Building dependency tree
Reading state information... Done
ubuntu-restricted-extras is already the newest version.

GautierPortet (kassoulet) wrote :
Changed in soundconverter:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → GautierPortet (kassoulet)
milestone: none → 2.1.4
Jason D. (tronman) wrote :

Thanks for the patch, I was having the same issue and this fixed it for me as well. Much appreciated!

Changed in soundconverter:
status: Confirmed → Fix Committed
Changed in soundconverter:
status: Fix Committed → Fix Released
Changed in soundconverter (Ubuntu):
importance: Undecided → High

@Gautier,@Jason
How did you manage to have the patched version of soundconverter?

@Everyone
Any chance to have this bug fixed in ubuntu repos sooner or later?

GautierPortet (kassoulet) wrote :

You can try to install this: http://www.getdeb.net/software/soundconverter
(not tested)

And the latest version will be on the next Ubuntu.

Thank you Gautier, I found another solution.

As described in https://answers.launchpad.net/soundconverter/+question/247332 you can also install this ppa:
ppa:mc3man/trusty-media
that adds gstreamer0.10-ffmpeg package to the repos. Installing it solves the problem.

Maybe someone could fill an SRU request pointing that the update has important fixes for it to work properly.

GautierPortet (kassoulet) wrote :

Thank you Michele!

For the interested people, please add themselves as affected by my request, so it become confirmed and not only new, and maybe some Ubuntu developer will notice it

@Gautier
Ubuntu bug team refused the request for now cause of some changes (like the new mp3 encoder). Could you provide a specific patch for this bug in order to minimize the changes from the version in the repos?

GautierPortet (kassoulet) wrote :

See comment in SRU.

Changed in soundconverter (Ubuntu Trusty):
importance: Undecided → High
status: New → Confirmed
Changed in soundconverter (Ubuntu):
status: Confirmed → Fix Released
summary: - Python (v2.7) requires to install plugins to play media files of the
- following typ
+ [SRU] Python (v2.7) requires to install plugins to play media files of
+ the following typ
description: updated

Hello Thibaut, or anyone else affected,

Accepted soundconverter into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/soundconverter/2.0.4-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in soundconverter (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed

* enable proposed repository & install soundconverter.

$ LANG=C apt-cache policy soundconverter
soundconverter:
  Installed: 2.0.4-0ubuntu1.1
  Candidate: 2.0.4-0ubuntu1.1
  Version table:
 *** 2.0.4-0ubuntu1.1 0
        400 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-proposed/universe i386 Packages
        100 /var/lib/dpkg/status
     2.0.4-0ubuntu1 0
        500 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty/universe i386 Packages

convert mp4(H.264) to mp3
---> Complete & No error.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package soundconverter - 2.0.4-0ubuntu1.1

---------------
soundconverter (2.0.4-0ubuntu1.1) trusty; urgency=low

  * New upstream stable branch bug fixes (LP: #1423709).
    - Ignore video codecs (LP: #1308187). Thanks to Thibaut
    - Empty task queue when aborting. Thanks to Michael.
    - Fix TypeError when calling show_error. Thanks to Michael
 -- Michele Giacomoli <email address hidden> Tue, 07 Apr 2015 00:45:43 +0200

Changed in soundconverter (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for soundconverter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers