progress bar fail to report correct progress

Bug #104450 reported by Noah Duffy
28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Undecided
Unassigned
soundconverter (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: soundconverter

Original Report:

Soundconverter's progress bar reports the incorrect overall progress of the conversion, while SoundConverter also fails to calculate the correct time remaining.

I'm using Ubuntu Feisty, and the SoundConverter package is version 0.9.4-0ubuntu1; architecture would be i386.

Appended by: Jarrod Henry

Ubuntu Version: Feisty

Software Version/Package: SoundConverter 0.9.4-0ubuntu1

Architecture: i386

Steps to Reproduce: Convert a sound file from one format to another.

Expected Action: The progress bar gives an estimation of time remaining and percentage of completion

Actual Action: The progress bar does not accurate represent the task's completion, and the time remaining is erratic.

Revision history for this message
Jarrod Henry (jarrodhenry) wrote :

Okay. I'll triage this one in. No duplicates.

Which version of Ubuntu are you using, and what soundconverter package is this?

You can find the package information by typing "dpkg -s soundconverter" .. What we're interested in is both the version and the architecture.

Also, if you could tell us what you were doing in the process of conversion ? Does it work better on estimation with some than on others, or is it all off?

Thanks!

Changed in soundconverter:
assignee: nobody → jarrodhenry
Revision history for this message
Noah Duffy (noah0504) wrote :

I'm using Ubuntu Feisty, and the SoundConverter package is version 0.9.4-0ubuntu1; architecture would be i386.

The error has occurred every time I've tried to convert files using the particular version of SoundConverter under Feisty. For the record, I only ever attempt to convert FLAC files to Ogg Vorbis. I've also noticed SoundConverter takes quite a long time to analyze the tags of the files I add to be converted. I'm not sure if that is a bug, but I never remember it taking long at all in previous versions. The last and final bug I've come across (I wanted to make this particular bug report quick and simple, however, since I've drawn attention to it, I decided to list the rest of my problems) occurs when I have SoundConverter place the converted files into the same directory as the input files: SoundConverter places the files into a directory folder outside of the input directory.

Sorry for adding even more problems to this bug report.

Revision history for this message
Jarrod Henry (jarrodhenry) wrote :

That's alright. More information is better than less. I'm going to go ahead and edit the text behind this bug and then test it myself, and it sounds like we can go ahead and confirm it. As for the other instances, I'd suspect those are not as much bugs as change requests and what not. We'll focus on the initial issue, and the others can be refiled if necessary.

Revision history for this message
Jarrod Henry (jarrodhenry) wrote :

Marking as low, and will contact the upstream.

description: updated
Changed in soundconverter:
status: Unconfirmed → Confirmed
Revision history for this message
Jarrod Henry (jarrodhenry) wrote :

Actually, I can't mark it as low. So I'll just contact upstream.

Changed in soundconverter:
assignee: jarrodhenry → nobody
William Grant (wgrant)
Changed in soundconverter:
importance: Undecided → Low
Revision history for this message
Noah Duffy (noah0504) wrote :

Thanks for taking notice and confirming the bug.

Revision history for this message
GautierPortet (kassoulet) wrote : Re: [Bug 104450] Re: progress bar fail to report correct progress

Using soundconverter_0.9.4-0ubuntu1 (in feisty) I'm not able to
reproduce any of the problems you reported.

Maybe a problem with gstreamer installation ?

--
Gautier Portet <kassoulet gmail com>
  --==-- http://kassoulet.free.fr --==--

Revision history for this message
Noah Duffy (noah0504) wrote :

Well, my experience is based off of several fresh installs of Feisty. Whether a GStreamer update solved the problem, I don't know. I'll have to try using SoundConverter a little later.

Revision history for this message
SebastienBarthelemy (barthelemy) wrote :

I have the same problem with Ubuntu Gutsy Tribe 5, soundconverter Version: 0.9.6-1, while converting files from flac to mp3.

On the screenshot you can see that the estimated remaining time is negative !

Revision history for this message
Paul (peubanks) wrote :

I might also add I've seen the progress bar indicate impossible file counts as well such as "Converting file 6 of 2" and then also display a negative estimated remaining time.

Revision history for this message
Nuno Santos (zoryn1) wrote :

Still having this problem with gutsy. The progress bar is stopped, no time is shown, but the conversion completes successfully

Revision history for this message
Hew (hew) wrote :

This bug report seems to cover a few different issues with the progress bar. My experience on Hardy 1.0.1-0ubuntu2:

The visible progress bar reports correctly for me; that is, the progress covers the correct amount of the bar.

The "Converting file x of y" issue where 'x' > 'y' can be reproduced by adding a queue and performing a conversion, removing the queue, adding a new one and converting again. 'x' doesn't appear to reset, so it just continues where it left off.

I haven't experienced the negative time issue on Hardy.

The estimating of time is not accurate. Doing a conversion of 400 files, the estimated time started at around 30min, and immediately climbed up over 200min. 40min in, and it's dropped to 120min and is dropping 10s every second.

Is this consistent with what others are seeing?

Revision history for this message
Gavin Hamill (gdh) wrote :

Confirming "x > y" - convert any file(s), press 'Clear', convert any file(s) and x increases from its previous value rather than resetting to 1.

William Grant (wgrant)
Changed in soundconverter:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package soundconverter - 1.2.0-0ubuntu1

---------------
soundconverter (1.2.0-0ubuntu1) intrepid; urgency=low

  * New upstream release.
    - Reset progress indiciator after a conversion. (LP: #104450)
  * debian/patches/fix-add_uris-crash.patch: Drop. Included upstream.

 -- William Grant <email address hidden> Wed, 04 Jun 2008 13:38:33 +1000

Changed in soundconverter:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers