Dedicated mono test sound is unavailable

Bug #1703946 reported by Will Cooke on 2017-07-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sound-theme-freedesktop (Ubuntu)
Medium
Will Cooke

Bug Description

When testing stereo speakers you get the "Front left" and "Front right" samples, but no such sample exists for mono speakers e.g. HSP/HFP bluetooth devices.

Instead you get played the "audio-test-signal" which is white noise. To begin with I thought this was a problem with Bluetooth or the speaker itself, but it's just the sample being used.

There is a bug upstream to provide this sample, but in the meantime I think playing the "audio-channel-front-center.oga" is a suitable standin.

Will Cooke (willcooke) wrote :

Simply symlinking works:

ln - s audio-channel-front-center.oga audio-channel-mono.oga

Will Cooke (willcooke) wrote :

debdiff to do the symlink

Will Cooke (willcooke) wrote :

As per: http://packaging.ubuntu.com/html/traditional-packaging.html#creating-a-debdiff
this patch includes an updated maintainers section in the debian/control file.

tags: added: desktop-trello-import
Will Cooke (willcooke) on 2017-07-12
description: updated

The attachment "sound-theme-freedesktop.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Daniel van Vugt (vanvugt) wrote :

Is UNRELEASED OK or do we want to change that to artful?

+sound-theme-freedesktop (0.8-1ubuntu1) UNRELEASED; urgency=medium

Will Cooke (willcooke) wrote :

debdiff with updated changelog per comment #7.

Changed in sound-theme-freedesktop (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Will Cooke (willcooke)
Didier Roche (didrocks) wrote :

This looks good! Sponsored :)

Changed in sound-theme-freedesktop (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sound-theme-freedesktop - 0.8-1ubuntu1

---------------
sound-theme-freedesktop (0.8-1ubuntu1) artful; urgency=medium

  * debian/sound-theme-freedesktop.links
    - Link front-center sample to audio-channel-mono so that testing a mono
      bluetooth speaker plays a real sound rather than just white noise.
      (LP: #1703946)
  * debian/control
    - Updated maintainers as per packaging.u.c

 -- Will Cooke <email address hidden> Wed, 12 Jul 2017 19:16:20 +0100

Changed in sound-theme-freedesktop (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

I have sound-theme-freedesktop (0.8-1ubuntu1) installed and still get white noise. Is something still missing?

Daniel van Vugt (vanvugt) wrote :

$ ls -l /usr/share/sounds/freedesktop/stereo/audio-channel-*
-rw-r--r-- 1 root root 17015 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-front-center.oga
-rw-r--r-- 1 root root 15675 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-front-left.oga
-rw-r--r-- 1 root root 19019 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-front-right.oga
lrwxrwxrwx 1 root root 30 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-mono.oga -> audio-channel-front-center.oga
-rw-r--r-- 1 root root 17099 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-rear-center.oga
-rw-r--r-- 1 root root 14129 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-rear-left.oga
-rw-r--r-- 1 root root 18791 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-rear-right.oga
-rw-r--r-- 1 root root 17089 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-side-left.oga
-rw-r--r-- 1 root root 17198 Jul 13 02:16 /usr/share/sounds/freedesktop/stereo/audio-channel-side-right.oga

Will Cooke (willcooke) wrote :

The files look right, and I can reproduce this on one of my test machines. I can't reproduce it anymore on an updated daily ISO. So I think this is something machine specific. Looking at the code it looks like canberra is failing to play the "new" sound and so failing back to play the test sound (white noise). I can't work out why it's doing this yet. I need to get more debug info out of libcanberra I think.

This might be futile though, if it works everywhere else.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.