track numbering lost leading zero

Bug #371150 reported by Fouche du Preez on 2009-05-03
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Sound Juicer
Fix Released
Medium
sound-juicer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: sound-juicer

Ubuntu Release: 9.04
Sound Juicer: 2.26.1

Expected behaviour:
When extracting an audio CD, the file names of track numbers below 10 should have a zero prefix for the track number part of the file name e.g: 01 - Some song.ogg

Actual behaviour:
No 0 prefix gets added to file name, the 1st track has a name such as: 1 - Some song.ogg

Comment:
This behaviour is new in Ubuntu 9.04 - I run previous versions of Ubuntu & Sound juicer where file naming works as it should. I went through the updates of Sound Juicer and think the bug got introduced when the disk number was added to the file name. It's fine to add the disc number to the file name, but keep the track numbering as it should be :)

wensveen (wensveen) wrote :

I can confirm this bug.
It's a little annoying to add this yourself, but there's bound to be some smart shell scripting trick for this. Someone?

It says "track number" but in fact it's "disc number - track number", but you can fix this.

1. Launch gconf-editor
2. Go to /apps/sound-juicer
3. Update the file_pattern and replace "%dN" by "%tN" (track number, zero padded).
4. Restart sound juicer

It's important to note that the drop down for the file pattern will be blank. Do not modify it, you'll have to do it again afterwards.

toby cabot (caboteria) wrote :

Thanks Antoine for the workaround!

To answer wensveen's question, this works for me (I've got the "strip special characters" option checked):
$ for i in [1-9]_* ; do mv "$i" "0$i" ; done

wensveen (wensveen) wrote :

Thanks for the workaround and the scripting bit.
Still a bug in sound-juicer though, isn't it?

toby cabot (caboteria) wrote :

I'd say it's a bug since the tracks show up in the wrong order when you "ls" the directory they're in, but it's a pretty low severity.

Joe Kilner (joekilner) wrote :

TH real problem for me is streaming music over rygel / DLNA - things come up sorted by filename which messes up long albums.

August Karlstrom (fusionfile) wrote :

I am also annoyed by the default setting. Is there any context where zero padded track numbers are disadvantageous? If not, let's just change the default format.

Joe Kilner (joekilner) wrote :

By the way, a fix for this bug (and the problems you get with 2CD sets) is to use musicbrainz Picard to tidy things up after a rip. It's an extra step, but I think it's worth it as it sets all metadata correctly including embedding album art if you want it to.

Phillip Susi (psusi) on 2012-02-26
Changed in sound-juicer (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Phillip Susi (psusi) wrote :

The upstream bug report appears to have a patch.

tags: added: patch
summary: - Incorrect track numbering
+ track numbering lost leading zero
tags: added: regression-release
Changed in sound-juicer:
importance: Unknown → Medium
status: Unknown → New
Changed in sound-juicer:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.