Ubuntu

sound-juicer crashes when pressing "Extract" button, with SIGSEGV in filepath_parse_pattern()

Reported by Lorenzo on 2009-02-15
348
This bug affects 87 people
Affects Status Importance Assigned to Milestone
Sound Juicer
Fix Released
Critical
libmusicbrainz
Fix Committed
Undecided
Unassigned
sound-juicer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: sound-juicer

Ubuntu jaunty (development branch) 9.04

sound-juicer 2.25.3-0ubuntu1

What I've done & what happened:

1) Inserted an audioCD
2) Lauched sound-juicer
3) clicked button to rip tracks
4) sound-juicer crashed!

ProblemType: Crash
Architecture: i386
CrashCounter: 1
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/sound-juicer
Package: sound-juicer 2.25.3-0ubuntu1
ProcCmdline: sound-juicer
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: sound-juicer
StacktraceTop:
 ?? ()
 filepath_parse_pattern ()
 ?? ()
 ?? ()
 on_extract_activate ()
Title: sound-juicer crashed with SIGSEGV in filepath_parse_pattern()
Uname: Linux 2.6.28-7-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare video

Lorenzo (lorped) wrote :

StacktraceTop:filepath_parse_pattern (pattern=0x967da70 "%aa/%at",
build_filename (track=0x9668c00, temp_filename=0,
pop_and_extract (overwrite_mode=0x8071bc4)
on_extract_activate (button=0x91fa578, user_data=0x0)
IA__g_cclosure_marshal_VOID__VOID (closure=0x94972d0,

Changed in sound-juicer:
importance: Undecided → Medium

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=572145

Changed in sound-juicer:
status: New → Triaged
Changed in sound-juicer:
status: Unknown → Confirmed
ec (ecroes) wrote :

Also happens on karmic 64 bit:
Linux cd-a03-5 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux
Ubuntu karmic (development branch) \n \l

Geïnstalleerd: 2.28.0-1
  Kandidaat: 2.28.0-1
  Versietabel:
 *** 2.28.0-1 0
        500 http://nl.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

guriinii (rgreen-5) wrote :

Also happens on karmic

bclintbe (bclintbe) wrote :

Happened to me in 10.04 Beta 1

Changed in sound-juicer:
status: Confirmed → Invalid
Stephen Warren (srwarren) wrote :

Upstream bug was marked as a dup; point bug-watch at new bug (why oh why do people mark older bugs as dups of newer bugs instead of marking the actual duplicates as dups of the original report???)

Changed in sound-juicer:
status: Invalid → Unknown
Stephen Warren (srwarren) wrote :

I believe the upstream bug covers any aspect of sound-juicer crashing due to any user-interface field being blank. As such, I'm going to mark a bunch of Ubuntu bugs as duplicates of this current bug, to clean up all the dups.

summary: - sound-juicer crashed with SIGSEGV in filepath_parse_pattern()
+ sound-juicer crashes when pressing "Extract" button, with SIGSEGV in
+ filepath_parse_pattern()
Stephen Warren (srwarren) wrote :

I have gone through all the duplicates of this bug and subscribed everyone to this bug so that everyone sees any future updates.

Stephen Warren (srwarren) wrote :

Note: This bug was originally reported against Jaunty development (9.04) but is still present in Lucid development (10.04) in package version 2.28.1-2 (and some dups were also reported against Karmic).

Well no sense spamming everyone.

Linux is awesome on the debug stuff, and stuff gets fixed quick but if
you want perfect and polished all the time you buy mac.

:D

  On 04/17/2010 12:04 PM, Stephen Warren wrote:
> I have gone through all the duplicates of this bug and subscribed
> everyone to this bug so that everyone sees any future updates.
>
>

Changed in sound-juicer:
status: Unknown → New
Changed in sound-juicer:
status: New → Incomplete
Stephen Warren (srwarren) wrote :

This bug has been fixed upstream (although launchpad hasn't noticed the status update yet). Can the patch please be pulled into Ubuntu Lucid. Thanks.

Changed in sound-juicer:
status: Incomplete → Fix Released
Changed in sound-juicer (Ubuntu):
status: Triaged → Fix Committed
mp (m-p) wrote :

When can a fix be expected for Lucid?

joseielpi (joseielpi) wrote :

I have the same bug in Lucid. Sound Juicer crashes when pressing the extract button.

I have this problem (Lucid Lynx - upgraded online from 8.04). I use this program a lot.
uname -a: Linux jmp-desktop 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 07:54:58 UTC 2010 i686 GNU/Linux

I want to add the messages that appear when launching sound-juicer via the command line:
"(sound-juicer:2890): Gtk-CRITICAL **: gtk_entry_set_text: assertion `text != NULL' failed

(sound-juicer:2890): Gtk-CRITICAL **: gtk_entry_set_text: assertion `text != NULL' failed

** (sound-juicer:2890): CRITICAL **: musicbrainz_submit_message_area_new: assertion `title != NULL' failed

(sound-juicer:2890): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(sound-juicer:2890): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

** (sound-juicer:2890): CRITICAL **: gedit_message_area_set_default_response: assertion `GEDIT_IS_MESSAGE_AREA (message_area)' failed

(sound-juicer:2890): Gtk-CRITICAL **: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed
Erreur de segmentation"

Only the first 7 lines are displayed when launching sound-juicer. Sometime this block of 7 lines is repeated two times.
Then, when I type the artist, its name synchronously displays on each track. This is not the case when I type the title: each track title field remain empty.
Then when I click Extract, the sound-juice window disapear and "Erreur de segmentation" is displayed as the last 8th line.

hope this helps.

Daniel Hollocher (chogydan) wrote :

still present in maverick

Changed in sound-juicer:
importance: Unknown → Critical
Josir (josir-jsk) wrote :

Sound Juicer 2.28.1 in Ubuntu 10.1 still have this bug.

Manual solution: fill all song titles and cd fields info and it will not break.

Daniel Hollocher (chogydan) wrote :

hey Josir, it looks like Maverick got an update since I posted, so it should be working now. Unfortunately, I don't have an un-databased cd to test with anymore.

@Daniel Hollocher can't you just grab some random sound files and burn a unique CDDA disk?

Daniel Hollocher (chogydan) wrote :

probably, but I found another cd, and it works. It looks like the fix just implements the manual fix behind the scenes, and doesn't really fix the under lying problem. If you delete the title and artist, and hit extract you get a bunch of errors that make no sense.

A mediocre fix, but at least it works.

marianitn (marianitn) wrote :

Any plans on backporting this "fixaround" to Lucid?

John Baptist (jepst79) wrote :

Since this still crashes when the Extract button is pressed, shouldn't the bug be reopened? Or should we create a new bug report?

Is this when we should switch to CentOS 6 or do we have to wait a few more month?

ByteSoup (bytesoup) wrote :

Problem is still present on 10.04 running 2.6.32-32-generic. You have to enter track titles to workaround.

Sergey Fukanchik (fuxx) wrote :

Attaching a fix. This fixes the problem for me on 10.04 LTS. Hopefully since it's LTS they will apply it and propagate to all the users.

Daniel Hollocher (chogydan) wrote :

hmmm, I doubt that it will be included sergey. I might take a look at that patch, see if it applies to whatever the next release is, and maybe open a new bug report to get it included.

The attachment "A patch to fix the bug." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Timo Aaltonen (tjaalton) wrote :

The fix is included in 12.04 which has s-j 3.4, not going to spend time on a SRU for 10.04

Changed in sound-juicer (Ubuntu):
status: Fix Committed → Fix Released
Sergey Fukanchik (fuxx) wrote :

Timo, if you point me to a guide i can spend my time on a update for 10.04.

Jonathan Allard (joallard) wrote :

Fixed in 4.0.2

Changed in libmusicbrainz:
status: New → Fix Committed
wilk (j-cubizolles) wrote :

Is there a deb file for 4.0.2 or newer ?

dukat (dukat) wrote :

I'd love to see an update/backport in Lucid, haven't found a PPA for it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.