No access to non-default sound format profiles

Bug #178652 reported by Emmanuel Charpentier on 2007-12-25
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Sound Juicer
New
Low
sound-juicer (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: sound-juicer

I cannot use a newly-created sound profile to rip to MP3 : this newly-created profile does not appear in the drop-down list of available profiles. Closing sound juicer and reopening does *not* cure the problem, nor does quitting-reopening.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, Which version of Ubuntu and Sound Juicer are you using? Does it works with another new user created on your system? that works fine for me here with Gutsy and Hardy, thanks.

Changed in sound-juicer:
assignee: nobody → desktop-bugs
status: New → Incomplete
Jason Allen (jasonrallen) wrote :

I am experiencing this problem on both Ubuntu Gutsy and Linux Mint. The profile editor seems to record changes to the text fields but does not show those changes in the available drop down menu. The MP3 profile is missing from the drop down on a fresh linux mint installation and wasn't available for use as of the first time sound juicer was launched. It was working on my Gutsy machine but one day it just disappeared from the available profile list. I used other ripping apps for a while and then one day I check sound juicer (weeks later) and there it was again. It worked for about two weeks then pulled another vanishing act.

I tried editing one of the profiles that I knew was appearing in the available list to use MP3 settings, but that just caused it to disappear from the list just like the stock MP3 profile. Creating a brand new profile saved the profile in the setting manager but it does not appear in the list when trying to encode files.

If I can provide any other info please let me know. I hope we can help you figure this out because sound juicer is the best I've used so far, thanks for the great work.

Toby Smithe (tsmithe) wrote :

I can confirm this bug on Gutsy. Whilst there seem to be profiles for mp3 active (by default, though I am not sure what package provides them), they are not selectable from withing the Sound Juicer preferences drop-down list. This also applies to the "Voice" profiles, too, and any profiles manually created.

Changed in sound-juicer:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks for your comments. This does not appear to be a bug report as such. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. http://launchpad.net/support. Those options are not available because you don't have the corresponding codecs installation, there is already a bug about automatically installing those when required

Changed in sound-juicer:
importance: Undecided → Low
status: Confirmed → Invalid
Toby Smithe (tsmithe) wrote :

Err, this is a totally valid bug. I have all the codes installed. Plainly, the profiles do not work. Ripping a CD tells me that the cdlossy profile cannot be found. Well, of course it can't; I can't even select it from the list. I don't even necessarily know that I want that profile. I just want mp3 output :) Creating profiles does not help: even if they are added to the gnome-audio-profiles-properties list, they do not appear in the drop-down for selection. Occasionally, when they have done, they do not allow me to rip anything.

Changed in sound-juicer:
status: Invalid → New
Toby Smithe (tsmithe) wrote :

Moreover, it is still applicable on Hardy, and has never not been.

Sebastien Bacher (seb128) wrote :

what codecs did you install exactly?

Changed in sound-juicer:
status: New → Incomplete
Jason Allen (jasonrallen) wrote :

I've tried every recommended codec package in every soundjuicer related forum thread I could find. But then I also gave up on using the application about 6 months ago due to this issue (nothing personal, I otherwise love the app and wish it could handle my encoding settings of choice correctly).

Let me know how I can check them for you and I'll be happy to provide all the info you need. Thanks for looking into this!

Sebastien Bacher (seb128) wrote :

could you run dpkg -l | grep gstreamer and attach that to a comment?

Jason Allen (jasonrallen) wrote :

I've since formatted my machine since I tried installing all the various codecs listed in forum threads, but here's what I have now on a Linux Mint installation, which has had this problem since I installed the OS.

  • dpkg-gst Edit (2.4 KiB, application/octet-stream; name=dpkg-gst)

On Fri, Apr 25, 2008 at 10:22 PM, Sebastien Bacher <email address hidden> wrote:
> what codecs did you install exactly?

All of them.

I am also experiencing this problem on Hardy. I removed all sound juicer related settings from ~/.config and ~/.gconf, then created a new custom profile called "test". It could not be selected from the drop-down menu, even after closing and re-opening Sound Juicer.

Not sure if it makes a difference, but the Gstreamer Pipeline entry for "test" was copied and pasted from a known working profile.

I have provided the URL of the upstream bug report.

Changed in sound-juicer:
status: Unknown → New
Changed in sound-juicer:
status: Incomplete → Triaged
Gaele Strootman (gaele) wrote :

I encountered this same bug.

Under Edit Profiles the following profiles are available:
- CD Quality, Lossless
- CD Quality, Lossy
- Voice, Lossless
- Voice, Lossy
- CD Quality, AAC
- CD Quality, MP3

All are active.

However, under Output Format only the first 4 profiles are available. Changing the "active" field on any of the profiles does not have any effect.

This made MP3 and AAC appear in the available Output Formats:
https://bugs.launchpad.net/ubuntu/+source/sound-juicer/+bug/195483/comments/19

There seem to be 2 bugs here:

- technical: the "active" field does not work
- usability: the "active" field should not be selectable if the underlying codecs are not available

John Boiles (johnaboiles) wrote :

I also have the exact same problem as Gaele. The link Gaele provided helped me get the MP3 and AAC profiles to work (Thank you very much).

A note about the "active" field; to change the active status of a profile I have to modify it, then restart sound juicer for the change to appear.

Paul Swanson (paul-swanson) wrote :

I have a recent installation of Ubuntu 8.10 (Intrepid Ibex) with all the updates and I also have this same problem.

Daniel Seither (tiwoc) wrote :

I also encountered the issue discussed in this bug (in Ubuntu 8.10):
- my self-created profile for MP3 did not show up
- the predefined profiles for AAC and MP3 did not show up either

When I ran sound-juicer from console, I encountered the following message on STDOUT/STDERR:

** (sound-juicer:30984): WARNING **: Profile warning: Kein Element »lame«

German "kein Element" means "no element". I could fix this by installing
- gstreamer0.10-plugins-ugly
- gstreamer0.10-plugins-ugly-multiverse

So, as Gaele already told us: This is a usability problem; profiles with unsatisfied dependencies just don't show up. At least, a warning message should be shown when creating or using such a pipeline. Automatic codec installation like in Totem would be nice to have, though.

startling (mark-starling) wrote :

I also have this problem in 8.10. I believe I have the codecs but only four of the profiles show up in the choice list. Creating new profiles does not help as these do not show up either.

jan (jan-ubuntu-h-i-s) wrote :

Confirmed in Ubuntu 9.04 - the Jaunty Jackalope .

jan (jan-ubuntu-h-i-s) wrote :

The problem, apparently, is that the application checks the presence of software that can be installed from:
gstreamer0.10-plugins-ugly-multiverse
If the software is not present, non-playable codecs are not shown
Unfortunately, the selection list does not show that this is the case, not is there any error log in which the user gets a hint of what is wrong.
Thus adding feedback in either the "edit" window, or greying-out impossible selections rather than not showing them at all, would stop this confusion.

Changed in sound-juicer:
importance: Unknown → Low
Flittermice (flittermice) wrote :

This bug still exists in 11.04 - my own profiles are not shown.
At the end I changed the standard profile "CD-Qualität, MP3" to the values I needed, but this is no sensible solution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.