Update to 3.5.0

Bug #1042015 reported by Robert Ancell on 2012-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sound-juicer (Ubuntu)
Wishlist
Unassigned

Bug Description

Sound Juicer "Je ne suis qu'une nonne dans la vie" 3.5.0
========================================================

* GStreamer 1.0 port (Sebastian Dröge)
* Remove use of some deprecated APIs (Bastien Nocera, Phillip Wood, phantomjinx)
* Various bug fixes (Christophe Fergeau)
* Translation updates:
        - Lithuanian (Aurimas Černius)
        - Catalan (Gil Forcada)
        - Danish (Joe Hansen)
        - Hebrew (Yaron Shahrabani)

Robert Ancell (robert-ancell) wrote :

Packaging updated in lp:~robert-ancell/sound-juicer/update-3.5.0 but this will probably have to be held back for Quantal since it requires gstreamer 1.0.

Changed in sound-juicer (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Robert Ancell (robert-ancell) wrote :

I have pushed this to the GNOME3 PPA

Jeremy Bicha (jbicha) wrote :

Robert, gstreamer 1.0 is in universe and so is sound-juicer so that's not a problem. I guess this will require clearance from the Release Team because of Feature Freeze though.

Robert Ancell (robert-ancell) wrote :

This might still be a problem if the paid MP3 codecs aren't available for GStreamer 1.0 in Quantal. Depends if we consider sound-juicer to be an important app (it is in main not universe). It's probably exempt from an exception as it's part of GNOME and that's traditionally exempt from feature freeze as long as we're just doing the standard updates to 3.6.

Jeremy Bicha (jbicha) wrote :

Oh I forgot about the fluendo mp3 plugin. Good point.

But maybe that's not a big deal either.

The version of gst-fluendo-mp3 in Debian is a bit old, 0.10.15. Looking at the changelog, 0.10.17 in April claims to optionally support the 0.11 API which I believe is the same as the 1.0 API.

https://core.fluendo.com/gstreamer/svn/trunk/gst-fluendo-mp3/ChangeLog

I guess we'd still be stuck with Totem 3.4 for 12.10 as it looks like Rhythmbox & Shotwell won't be ready & Seb doesn't want to mix gstreamer libs on the CD.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sound-juicer - 3.5.0-0ubuntu1

---------------
sound-juicer (3.5.0-0ubuntu1) raring; urgency=low

  [ Robert Ancell ]
  * New upstream release (LP: #1042015)
  * debian/control:
    - Use GStreamer 1.0 depends
    - Bump build-depends on libglib2.0-dev
  * debian/patches/0001-Use-musicbrainz5-drop-earlier-versions.patch:
    - Applied upstream

  [ Iain Lane ]
  * debian/patches/fix-gstreamer-elements-check-for-1.0.patch: Fix check to
    use 1.0 macro. Backported from upstream.
 -- Iain Lane <email address hidden> Thu, 29 Nov 2012 17:58:39 +0000

Changed in sound-juicer (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers