soprano crashes on multiple simultaneous queries

Bug #576660 reported by jamboarder on 2010-05-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
soprano (Ubuntu)
Medium
Jonathan Thomas
Lucid
Medium
Jonathan Thomas

Bug Description

##SRU Info added by Jonathan Thomas##
Impact: Makes the bangarang package largely unusable.
Addressed by: Upstream released a fix in soprano 2.4.3. Once maverick opens, this version will be uploaded.
Patch: I took the svn commit mentioned in comment #1 from upstream svn and applied it to the current lucid package. The patch fixes the isConnected() function so that a new ClientModel is not made for each soprano query.
Testcase: Scroll through all the items in the "Media List" side-pane. Doing it too fast will cause the crash.
Regression potential: Pretty low, small patch. Non-intrusive.
##########################

Binary package hint: libsoprano4

Found in Kubuntu 10.04
libsoprano4 package version 2.4.2

There is a bug in Soprano 2.4.2 that causes a crash when multiple simultaneous nepomuk queries are launched. This can be replicated in the packaged version of Bangarang (1.0.1) and in the developement version of bangarang. It may be possible in other ways, maybe by attempting to do simultaneous searches in Dolphin.

Soprano 2.4.3, released on April 24th, 2010, fixes the issue.

Jonathan Thomas (echidnaman) wrote :

We can push through the crash fix as an Stable Release Update: http://websvn.kde.org/?view=revision&revision=1117465
(Once we get the packages into lucid-proposed, we'll need testers to test to see if the bug works/to see if there are any regressions)

We can't introduce the new version, though, since it's not absolutely certain that there won't be regressions with the other changes the new version introduces.

Changed in soprano (Ubuntu):
assignee: nobody → Jonathan Thomas (echidnaman)
status: New → Triaged
Changed in soprano (Ubuntu):
importance: Undecided → Medium
status: Triaged → In Progress
description: updated
description: updated
Jonathan Thomas (echidnaman) wrote :

 * Please describe the change that is actually being made (ie. the commit message is pretty descriptive and would be a good start).
 * Please describe how this change fixes this bug.
 * Although the patch being done upstream and upstream history can be a factor in your regression analysis, the meat and potatoes should be based on the actual change you're proposing.

description: updated
description: updated
Changed in soprano (Ubuntu Lucid):
assignee: nobody → Jonathan Thomas (echidnaman)
importance: Undecided → Medium
milestone: none → lucid-updates
John Dong (jdong) wrote :

After discussing this bug with Jonathan in #ubuntu-motu, I am giving a SRU ACK for the debdiff

Changed in soprano (Ubuntu Lucid):
status: New → In Progress

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in soprano (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Jonathan Thomas (echidnaman) wrote :

For the record, this solved the bangarang crashes for me. I would like for this to be verified by jamboarder before the verification process is considered done.

jamboarder (jamboarder) wrote :

Tested with libsoprano4 version 2.4.2+dfsg.1-0ubuntu1.1 in
lucid-proposed. I can no longer duplicate the bug. It appears to be
fixed.

Thanks much and let me know if there is anything else I can do.

Jonathan Thomas (echidnaman) wrote :

Thanks. The package should be copied to the lucid-updates repository within a few days.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package soprano - 2.4.2+dfsg.1-0ubuntu1.1

---------------
soprano (2.4.2+dfsg.1-0ubuntu1.1) lucid-proposed; urgency=low

  * Add kubuntu_02_fix_clientmodel_crashes.diff from upstream to fix each
    soprano query from creating a new ClientModel (LP: #576660)
 -- Jonathan Thomas <email address hidden> Fri, 07 May 2010 09:40:52 -0400

Changed in soprano (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick.

Changed in soprano (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers