make soprano depending on virtuoso-opensource

Bug #505653 reported by Hans Bakker on 2010-01-10
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
soprano (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Harald Sitter

Bug Description

Because Nepomuk in KDE 4.4 needs Virtuoso, and there is a package released (https://launchpad.net/ubuntu/+source/virtuoso-opensource) for that now, it would be very practical to automatically install Virtuoso when Soprano is installed.

FriedChicken (domlyons) wrote :

I guess it's a duplicate of #331757

Jonathan Thomas (echidnaman) wrote :

But virtuoso is already packaged. This is totally different.

Jonathan Thomas (echidnaman) wrote :

Fixed with the latest updates.

Changed in soprano (Ubuntu):
status: New → Fix Released
Changed in soprano (Ubuntu):
status: Fix Released → Confirmed
Hans Bakker (hansmbakker) wrote :

soprano-daemon now recommends virtuoso-server and virtuoso-drivers, but I think this is not enough as it will complain about virtuoso not being installed until it is installed.
As soprano is useless without virtuoso it should depend on it and not only recommend it.

Strigi and Nepomuk need virtuoso as soprano-backend, and Nepomuk is needed by Akonadi, so it seems quite logical not having to install virtuoso by hand

Jonathan Thomas (echidnaman) wrote :

It'll be installed by default by virtue of being a recommended package, but we're not going to force it on anybody.

Changed in soprano (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers