Does not go past the loading screen

Bug #86736 reported by donatello on 2007-02-21
Affects Status Importance Assigned to Milestone
solarwolf (Debian)
solarwolf (Ubuntu)

Bug Description

Binary package hint: solarwolf

I installed the game successfully and tried to play it.
The game does not go past the loading screen in edgy. It is really frustrating because this happened in dapper too. The game worked well in suse. At that time i don't think it used pygame.

Stuart Langridge (sil) wrote :

This appears to actually be a bug in pygame, which spins forever when some bold or italic fonts are requested. Observe that this hangs:

python -c "import pygame, pygame.font; pygame.font.init(); print pygame.font.SysFont('sans', 14, 1, 1)"

The following patch to /usr/lib/games/solarwolf/ works around the problem:

--- 2007-03-18 15:02:09.000000000 +0000
+++ 2007-03-18 15:00:50.000000000 +0000
@@ -24,6 +24,8 @@
         if FontPool.has_key(val):
             font = FontPool[val]
+ italic = 0
+ bold = 0 # some not found
             font = SysFont(name, size, bold, italic)
             FontPool[val] = font
         self.font = font

Ralph Janke (txwikinger) wrote :

I can confirm this problem in hardy BETA.

Changed in solarwolf:
importance: Undecided → Medium
status: New → Confirmed
illume (illume) wrote :


upgrading to pygame 1.8 fixes this bug(and lots of others).

Please upgrade pygame to the latest version.


Changed in solarwolf:
status: Unknown → New
David Collins (davidapc) wrote :

For 10.04, Solarwolf 1.5-2 ran perfectly. I played the first few levels, hit ESC, entered my name for the high score and quit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.