Ubuntu

add-apt-repository crashed with SIGSEGV in visit_decref()

Reported by valeriocd on 2012-04-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Unassigned

Bug Description

...

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: python-software-properties 0.82.7
Uname: Linux 3.3.0-030300-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CrashCounter: 1
Date: Thu Apr 19 18:11:00 2012
ExecutablePath: /usr/bin/add-apt-repository
InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64 (20110719.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apt-add-repository
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x556590: mov 0x8(%rdi),%rax
 PC (0x00556590) ok
 source "0x8(%rdi)" (0x7f396a8bd728) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: software-properties
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 _PyObject_GC_Malloc ()
 PyTuple_New ()
Title: add-apt-repository crashed with SIGSEGV in _PyObject_GC_Malloc()
UpgradeStatus: Upgraded to precise on 2012-04-18 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare scanner src vboxusers

valeriocd (valeriocd) wrote :

StacktraceTop:
 visit_decref ()
 func_traverse.15009 ()
 collect.48493 ()
 _PyObject_GC_Malloc ()
 PyTuple_New ()

Changed in software-properties (Ubuntu):
importance: Undecided → Medium
summary: - add-apt-repository crashed with SIGSEGV in _PyObject_GC_Malloc()
+ add-apt-repository crashed with SIGSEGV in visit_decref()
tags: removed: need-amd64-retrace
Robert Roth (evfool) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

visibility: private → public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers