software-properties-kde mirror dialog crashes

Bug #96201 reported by Podolcsák Ádám on 2007-03-26
4
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Jonathan Riddell

Bug Description

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 376, in on_combobox_server_changed
    res = dialogue.run()
  File "/usr/lib/python2.5/site-packages/softwareproperties/kde/DialogMirror.py", line 132, in run
    mirror = self.mirror_map[text]
KeyError: u'\xcdrorsz\xe1g'

Related branches

Podolcsák Ádám (competterra) wrote :

sources list

Podolcsák Ádám (competterra) wrote :

sources list

Michael Vogt (mvo) on 2007-03-26
Changed in software-properties:
assignee: nobody → jr
Michael Vogt (mvo) on 2007-03-26
Changed in software-properties:
status: Unconfirmed → Confirmed
Jonathan Riddell (jr) wrote :

I can't recreate this. Please provide step by step instructions for recreating it (using latest software-properties-kde). Thanks

Changed in software-properties (Ubuntu):
importance: Undecided → Medium
amichair (amichai2) wrote :

I managed to recreate a similar bug on karmic, which looks like the updated version of the same root bug as this post from 2 years ago:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/DialogMirror.py", line 117, in on_treeview_mirrors_cursor_changed
    mirror = self.mirror_map[hostname]
KeyError: u'\u041c\u0430\u043b\u0430\u0439\u0437\u0438\u044f'

Steps to recreate:
1. boot karmic livecd and select Russian from the language boot menu
2. run software-properties-kde
3. select 'Other...' (russian equivalent) form the mirrors combobox
4. select a country title (a parent node, not an actual mirror url child, and not the expanding '+' - just the title itself)

Note: you may need to apply the fix for bug #464707 first, as it masks this bug by preventing the mirrors selection dialog from ever opening...

amichair (amichai2) on 2009-11-08
summary: - Installer Crashed
+ software-properties-kde mirror dialog crashes
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.75.5

---------------
software-properties (0.75.5) lucid; urgency=low

  [ Harald Sitter ]
  * KDE frontend: replace old manual listing of file endings for key import
    with mimetype based model (no need to support old stuff since it is so
    incredibly wrong... ending-wise that is)

  [ Amichai Rothman ]
  * Fix import of keys with non-ascii filename (LP: #350485)
  * Add source line input validation when adding a new source (LP: #116445)
  * Fix selected item and edit/remove button state after toggling a source
  * Fix alternate mirror selection corrupting sources.list (LP: #464707)
  * Fix selected mirror not shown in combobox (LP: #96110)
  * Fix mirror selection dialog error in non-ascii locale (LP: #96201)
  * Fix crash when modifying sources selection (LP: #102792)
  * Fix error handling when ppa key is missing (LP: #475220)
  * Improve keyboard tab order in some dialogs (LP: #464569)
  * Fix and improve mirror test and GUI (LP: #223047)
  * Fix mirror test timeout handling (LP: #456365)
  * Fix i18n, accelerators and styling on all dialogs (LP: #102773)
  * Fix utf8 in edit source dialog comments (LP: #489960)
 -- Amichai Rothman <email address hidden> Mon, 07 Dec 2009 14:46:38 +0200

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments