Ubuntu

add-apt-repository crashed with error in get_ppa_info_from_lp(): (23, 'Failed writing body (0 != 1607)')

Reported by fabioguerras on 2012-02-19
68
This bug affects 10 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Close in start.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: python-software-properties 0.82.4
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic-pae 3.2.6
Uname: Linux 3.2.0-16-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sat Feb 18 03:15:16 2012
DuplicateOf: https://bugs.launchpad.net/bugs/930478
ExecutablePath: /usr/bin/add-apt-repository
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/add-apt-repository ppa:ricotz/testing
PythonArgs: ['/usr/bin/add-apt-repository', 'ppa:ricotz/testing']
SourcePackage: software-properties
Title: add-apt-repository crashed with error in get_ppa_info_from_lp(): (23, 'Failed writing body (0 != 1607)')
UpgradeStatus: Upgraded to precise on 2012-02-16 (3 days ago)
UserGroups:

fabioguerras (fabioguerras) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

There is a bug with a similar signature ranked 4rd on errors.ubuntu.com (over 2100 reports yesterday), the error is sometime different though:

  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
    curl.perform()
error: (6, "Couldn't resolve host 'launchpad.net'")

Michael, do you think you could have a look or don't error out of connection issues?

Changed in software-properties (Ubuntu):
importance: Medium → High
Changed in software-properties (Ubuntu Precise):
importance: Undecided → High
milestone: none → precise-updates
status: New → Confirmed
assignee: nobody → Michael Vogt (mvo)
jordie9 (jordie9) wrote :

file "/usr/bin/add-apt-repository", line 125, in ,module> ppa_info = get_info_from_lp (user,ppa_name)
file "usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp curl.perform () pycurl.error: 6, "couldn't resolve host 'launchpad.net'"

after fresh install

Thanx for help

ByungGulRyu (baramryu) on 2012-07-04
Changed in software-properties (Ubuntu):
assignee: nobody → ByungGulRyu (baramryu)
status: Confirmed → New
Sebastien Bacher (seb128) wrote :

Didier, is there any chance that you look at this one as well (or get mvo to look at it by asking questions on how to fix it if needed ;-)

The bug scored 916 reports in 5 days on errors.ubuntu.com in July

Changed in software-properties (Ubuntu Precise):
milestone: precise-updates → ubuntu-12.04.1
assignee: Michael Vogt (mvo) → Didier Roche (didrocks)
Stéphane Graber (stgraber) wrote :

The initial backtrace and the can't resolve backtrace seem to be quite different.
The first looks like it would be triggered by some bad data coming over https where the other one is simply because resolving fails.

Catching the DNS resolution problem should be trivial, the initial traceback isn't exactly clear on what's going on though.

Changed in software-properties (Ubuntu):
status: New → Triaged
Changed in software-properties (Ubuntu Precise):
status: Confirmed → Triaged
Changed in software-properties (Ubuntu):
assignee: ByungGulRyu (baramryu) → nobody
Brian Murray (brian-murray) wrote :

Part of the reason there are two different tracebaks is that the duplicate database doesn't consider enough of the Traceback for the signatures to be unique:

936186 /usr/bin/add-apt-repository:error:<module>:get_ppa_info_from_lp

I suggest that we fix the issue that is being reported on errors.ubuntu.com.

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 125, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
    curl.perform()
error: (7, "couldn't connect to host")

Brian Murray (brian-murray) wrote :

Additionally, based of data obtained from errors.ubuntu.com, (https://errors.ubuntu.com/bucket/?id=%2Fusr%2Fbin%2Fadd-apt-repository%3Aerror%3A%3Cmodule%3E%3Aget_ppa_info_from_lp), and since Quantal no longer uses curl but rather urllib2 this bug is fixed in Quantal.

Changed in software-properties (Ubuntu):
status: Triaged → Fix Released
Changed in software-properties (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2
cmcanulty (cmcanulty) wrote :

same problem here jus started this morning
cmcanulty@HPTech:~$ sudo add-apt-repository ppa:gnome3-team/gnome3
[sudo] password for cmcanulty:
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 125, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
    curl.perform()
pycurl.error: (6, "Couldn't resolve host 'launchpad.net'")
cmcanulty@HPTech:~$

Colin Watson (cjwatson) on 2013-02-13
Changed in software-properties (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3
Didier Roche (didrocks) on 2013-04-23
Changed in software-properties (Ubuntu Precise):
assignee: Didier Roche (didrocks) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers