add-apt-repository crashed with AttributeError in add_source_from_line(): 'SoftwareProperties' object has no attribute 'KeysModified'

Bug #926152 reported by Chealdo Ortiga on 2012-02-03
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Marc Deslauriers
Precise
Medium
Marc Deslauriers

Bug Description

just added a ppa displays this error.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: python-software-properties 0.82.3
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
Uname: Linux 3.2.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Fri Feb 3 23:49:24 2012
ExecutablePath: /usr/bin/add-apt-repository
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/add-apt-repository ppa:unity-team/ppa
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_PH.UTF-8
 LANGUAGE=en_PH:en
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/add-apt-repository', 'ppa:unity-team/ppa']
SourcePackage: software-properties
Title: add-apt-repository crashed with AttributeError in add_source_from_line(): 'SoftwareProperties' object has no attribute 'KeysModified'
UpgradeStatus: Upgraded to precise on 2012-02-03 (0 days ago)
UserGroups:

Chealdo Ortiga (scriptwarlock) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in software-properties (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in software-properties (Ubuntu Precise):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.82.4

---------------
software-properties (0.82.4) precise; urgency=low

  * Move KeysModified signal so add-apt-repository doesn't crash.
    (LP: #926152)
 -- Marc Deslauriers <email address hidden> Fri, 03 Feb 2012 15:54:57 -0500

Changed in software-properties (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers