add-apt-repository: confirmation question is a CLI UI regression, breaking scripts

Bug #890708 reported by Monty Taylor on 2011-11-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Bartosz Kosiorek

Bug Description

TEST CASE:
1. run: sudo add-apt-repository ppa:mvo
2. verify that it prompts
3. install software-properties from oneiric-proposed
4. run: sudo FORCE_ADD_APT_REPOSITORY=1 add-apt-repository ppa:mvo
5. verify that it does *not* prompt

The addition in oneiric of a confirmation question as the default behavior for add-apt-repository is a change in behavior which breaks all scripts that were using add-apt-repository and most every code snippet on the web which explains how to install software from a PPA. (the instructions still work in sequence, but if someone wants to just highlight three lines which add the repo, run update, and then install the package, the second two get eaten by the prompt) Additionally, although there is a new -y option which enables the old behavior, this option did not exist in pre-oneiric, it becomes quite klunky to write system automation scripts which work across releases.

It seems that this causes many more problems than it solves, imho.

Dave Walker (davewalker) on 2011-11-15
summary: - Confirmation question is a UI regression breaking scripts
+ add-apt-repository: confirmation question is a CLI UI regression,
+ breaking scripts
Michael Vogt (mvo) on 2011-11-30
Changed in software-properties (Ubuntu):
status: New → In Progress
Changed in software-properties (Ubuntu Oneiric):
status: New → In Progress
description: updated
Changed in software-properties (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → Fix Released

Hello Monty, or anyone else affected,

Accepted software-properties into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-properties (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

Well it works as intended now as long as you use the 'Force...'option, though that doesn't seem to be the intent of the orig. reporter, I *think* he was requesting the removal of the prompt altogether.

Either way the Test Case doesn't make much sense, 1 & 4 should be reversed or 4 should be the same as 1 if bug was on removing prompt by default

Bartosz Kosiorek (gang65) wrote :

With the package from proposed the option "FORCE_ADD_APT_REPOSITORY=1" is works perfeclty for me.
There is no prompt, that's why it could be used in old scripts.

Verification successfully.

description: updated
Changed in software-properties (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
Changed in software-properties (Ubuntu Oneiric):
assignee: nobody → Bartosz Kosiorek (gang65)
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.81.13.2

---------------
software-properties (0.81.13.2) oneiric-proposed; urgency=low

  * add-apt-repository:
    - honor FORCE_ADD_APT_REPOSITORY (LP: #890708)
 -- Michael Vogt <email address hidden> Wed, 30 Nov 2011 09:46:12 +0100

Changed in software-properties (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers