oneiric-backports enabled by default in software-properties

Bug #840135 reported by Rigved Rakshit on 2011-09-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu oneiric (development branch)
Release: 11.10
software-properties-gtk:
  Installed: 0.81.9
  Candidate: 0.81.9
  Version table:
 *** 0.81.9 0
        500 http://in.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
Expected Outcome: oneiric-backports should be disabled by default
Actual Outcome: oneiric-backports was enabled by default

Proposed release note:

= Backports are now more easily accessible =

To enable users to more easily receive new versions of software, the Ubuntu Backports repository is now enabled by default. Packages from backports will not be installed by default — they must explicitly be selected in package management software. However, once installed, packages from backports will automatically be upgraded to newer versions.

Rigved Rakshit (rigved) wrote :
Stefano Rivera (stefanor) wrote :

This was by design, as backports are now safe to have enabled for everyone. apt won't install anything from backports without the user requesting it. And will install updates for packages already installed from backports.

The UDS discussion was https://blueprints.launchpad.net/ubuntu/+spec/foundations-o-backports-bof

The related UI changes (not done yet) https://blueprints.launchpad.net/ubuntu/+spec/foundations-o-backports-ui

Changed in software-properties (Ubuntu):
status: New → Invalid
description: updated
Dave Walker (davewalker) wrote :

Marking the ubuntu-release-notes task Invalid, as this is not a bug and produces no changed user behaviour.

Thanks

Changed in ubuntu-release-notes:
status: New → Invalid
Scott Kitterman (kitterman) wrote :

release notes task back to New after IRC discussion.

Changed in ubuntu-release-notes:
status: Invalid → New
Iain Lane (laney) on 2011-10-12
description: updated
Changed in ubuntu-release-notes:
status: New → Fix Committed
Andy Whitcroft (apw) on 2012-04-26
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers