apt-add-repository --remove doesn't remove deb-src entry

Bug #838507 reported by joopbraak on 2011-09-01
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Low
Robert Roth
Oneiric
Undecided
Unassigned

Bug Description

Adding a PPA with apt-add-repository adds deb and deb-src lines in a new list file in /etc/apt/sources.list.d/.

Removing it with apt-add-repository --remove only removes the deb entry in that list file in /etc/apt/sources.list.d/, the deb-src entry is still there though.

It should remove the whole list file.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: python-software-properties 0.80.9
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: wl fglrx
Architecture: amd64
Date: Thu Sep 1 02:56:12 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110216)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: Upgraded to natty on 2011-03-22 (162 days ago)

Related branches

joopbraak (joopbraak) wrote :
joopbraak (joopbraak) on 2011-09-01
description: updated
Changed in software-properties (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Michael Vogt (mvo)
Robert Roth (evfool) on 2011-10-15
Changed in software-properties (Ubuntu):
status: Confirmed → In Progress
assignee: Michael Vogt (mvo) → Robert Roth (evfool)
Gregory Margo (gmargo) wrote :

The proposed fix still does not address the missing documentation mentioned in the older bug report comment #2:

Additional related bug: The --remove option is not documented in the add-apt-repository(1) man page.

Robert Roth (evfool) wrote :

@Gregory Margo: thanks for pointing that out, I have updated the branch with the manpage update with all the options documented and some other minor changes.

Robert Roth (evfool) on 2011-10-26
Changed in software-properties (Ubuntu):
status: In Progress → Fix Committed

Hello joopbraak, or anyone else affected,

Accepted software-properties into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.81.13.1

---------------
software-properties (0.81.13.1) oneiric-proposed; urgency=low

  [ Michael Vogt ]
  * debian/control:
    - add missing build-depends to dh-translations

  [ Philip Muskovac ]
  * lp:~yofel/software-properties/lp-819793:
    - Fix for bug 819793 as disable_child_source() now need the template
      name as parameter, not the template itself )LP: #819793

  [ Robert Roth ]
  * Fix warnings logged to terminal about inexistent handlers by checking
    if the handlers exist
  * Reset the popcon checkbox value if changed, but auth failed (LP: #874759)
  * Apt-add-repository --remove changed to also remove the debsrc
    line (LP: #838507)
  * Update the manpage of apt-add-repository with the available
    options. (LP: #697546)
  * Reset the text on the mirror testing dialog after closing/canceling
    it (LP: #875679)
  * Unicode encode PPA description and displaynam to avoid
    UnicodeDecodeErrors (LP: #827355)
  * Do not expand the server combobox (LP: #875131)

software-properties (0.81.13) oneiric-proposed; urgency=low

  * lp:~kelemeng/software-properties/bug853231:
    - Build with dh_translations, to localize the .policy file at
      runtime. LP: #853231
    - Add missing files to POTFILES.in (LP: #853231)
      Many thanks to Gabor Kelemen
 -- Michael Vogt <email address hidden> Thu, 20 Oct 2011 13:46:08 +0200

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
joopbraak (joopbraak) wrote :

This is not solved at all.

The same problem still exists, and, even worse, when trying to add the ppa again after having removed it with "apt-add-repository --remove" (the src entry still there), you get a corrupt list file in /etc/apt/sources.list.d/ with a src entry.

Yes, the line starts with src, not deb or deb-src.

Synaptic then throws an error and immediately closes.

tags: added: oneiric regression-update
removed: natty verification-needed
Changed in software-properties (Ubuntu):
status: Fix Released → Confirmed
joopbraak (joopbraak) wrote :

Sorry for not testing this sooner while it was in proposed btw. I'm still using natty on my main machine.

Clint Byrum (clint-fewbar) wrote :

How did this get copied to oneiric-updates? It never passed verification!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu Oneiric):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.82

---------------
software-properties (0.82) precise; urgency=low

  [ Manish Sinha (मनीष सिन्हा) ]
  * lp:~manishsinha/software-properties/fix-887249-handle-404-error:
    - improve error handling for incorrect/misspelled PPAs (LP: #887249)
  * lp:~manishsinha/software-properties/list-ppa-names-for-user-or-team:
    - Made the change to alert the user that a user/team does not have any PPAs

  [ Robert Roth ]
  * lp:~evfool/software-properties/lintianfixes:
    - Fixed capitalization issue in control file
  * Fix warnings logged to terminal about inexistent handlers by checking
    if the handlers exist
  * Change geeky authentication text displayed on policykit auth dialog to
    the one suggested by mpt (LP: #828285)
  * Reset the popcon checkbox value if changed, but auth failed (LP: #874759)
  * Apt-add-repository --remove changed to also remove the debsrc
    line (LP: #838507)
  * Apt-add-repository PPA warning changed to warn you about add/removal
    depending on what you really want to do.
  * Update the manpage of apt-add-repository with the available
    options. (LP: #697546)
  * Reset the text on the mirror testing dialog after closing/canceling
    it (LP: #875679)
  * Unicode encode PPA description and displaynam to avoid
    UnicodeDecodeErrors (LP: #827355)
  * Do not expand the server combobox (LP: #875131)
 -- Michael Vogt <email address hidden> Mon, 21 Nov 2011 16:32:49 +0100

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Released
Dmitry Shachnev (mitya57) wrote :
tags: added: patch
removed: regression-update
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in software-properties (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers