software-properties-gtk crashed with UnicodeEncodeError in ToggleSourceUse(): 'ascii' codec can't encode character u'\xe9' in position 72: ordinal not in range(128)

Bug #831652 reported by tatiwata on 2011-08-22
176
This bug affects 41 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

software-properties crashes while trying to delete repository-sources in synaptic.
Restarting synaptic after the crash still shows up the repo meant to be removed, crashes again as I try to remove it over again.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-properties-gtk 0.81.9
ProcVersionSignature: Ubuntu 3.0.0-9.12-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Aug 22 23:30:25 2011
ExecutablePath: /usr/bin/software-properties-gtk
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-properties-gtk -n -t 81789057
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_CH.UTF-8
 LANGUAGE=fr_CH:en
 LC_MESSAGES=fr_CH.UTF-8
 PATH=(custom, no user)
PythonArgs: ['/usr/bin/software-properties-gtk', '-n', '-t', '81789057']
SourcePackage: software-properties
Title: software-properties-gtk crashed with UnicodeEncodeError in ToggleSourceUse(): 'ascii' codec can't encode character u'\xe9' in position 72: ordinal not in range(128)
UpgradeStatus: Upgraded to oneiric on 2011-08-20 (2 days ago)
UserGroups:

visibility: private → public
tags: removed: need-duplicate-check
Changed in software-properties (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: removed: bugpattern-needed
Dmitry Shachnev (mitya57) wrote :

This bug tends to collect duplicates. Michael, can you look at it please?

tags: removed: amd64
Olosta (hameltho) wrote :

I have the impression that this bug is linked to the parsing of this kind of repo file (notice the non ASCII characters in the comments):
$ cat mozillateam-thunderbird-stable-natty.list
# deb http://ppa.launchpad.net/mozillateam/thunderbird-stable/ubuntu oneiric main # désactivé pour la mise à niveau vers oneiric
# deb-src http://ppa.launchpad.net/mozillateam/thunderbird-stable/ubuntu oneiric main # désactivé pour la mise à niveau vers oneiric

This is a big problem because the accents (é, à...) are added by the Ubuntu upgrade tool....

MARTIN Francois (fmartin2) wrote :

for several weeks, this bug had disappeared with an update. Today again the problem and crash!

Camille Appert (bibinou) wrote :

Seems like it was related to bug #846044, which is now fixed.

Changed in software-properties (Ubuntu Oneiric):
status: Triaged → Fix Released
Dave Gilbert (ubuntu-treblig) wrote :

Bibinou says he made a mistake and didn't actually want to mark it as fixed.

Changed in software-properties (Ubuntu Oneiric):
status: Fix Released → Triaged
Robert Roth (evfool) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug #820028, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers