software-properties-gtk crashed with UnicodeEncodeError in RemoveSource(): 'ascii' codec can't encode characters in position 99-100: ordinal not in range(128)

Bug #820028 reported by dmiranda on 2011-08-02
310
This bug affects 70 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

software properties crashed when using synaptic

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-properties-gtk 0.81.4
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue Aug 2 17:35:00 2011
ExecutablePath: /usr/bin/software-properties-gtk
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-properties-gtk -n -t 54525989
ProcEnviron:
 LANGUAGE=pt_BR:en
 PATH=(custom, no user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-properties-gtk', '-n', '-t', '54525989']
SourcePackage: software-properties
Title: software-properties-gtk crashed with UnicodeEncodeError in RemoveSource(): 'ascii' codec can't encode characters in position 99-100: ordinal not in range(128)
UpgradeStatus: Upgraded to oneiric on 2011-07-31 (1 days ago)
UserGroups:

dmiranda (dmiranda) wrote :
tags: removed: need-duplicate-check
Changed in software-properties (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Kate Stewart (kate.stewart) wrote :

marking high based on number of duplicates and people affected.

Changed in software-properties (Ubuntu):
importance: Undecided → High
tags: added: rls-mgr-o-tracking
Brian Murray (brian-murray) wrote :

This looks different than bug 846044 but might not be.

Steve Langasek (vorlon) on 2011-10-06
Changed in software-properties (Ubuntu Oneiric):
milestone: none → oneiric-updates
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Changed in software-properties (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I tried to reproduce this with the latest oneiric image. I tried the following:
$ LANGUAGE=pt_BR software-properties-gtk
$ sudo LANGUAGE=pt_BR synaptic - and then I clicked on Configuracao/Repositorios

Both times I got what looks like a normal translated window but I was not able to reproduce the crash.
I assume this is releated to your /etc/apt/sources.list, could you please attach it?

Michael Vogt (mvo) wrote :

I can reproduce this now.

Changed in software-properties (Ubuntu Oneiric):
status: Confirmed → In Progress
Changed in software-properties (Ubuntu Precise):
status: Confirmed → In Progress
Michael Vogt (mvo) on 2011-10-10
Changed in software-properties (Ubuntu Oneiric):
status: In Progress → Fix Committed
Changed in software-properties (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.81.10

---------------
software-properties (0.81.10) oneiric; urgency=low

  * softwareproperties/dbus/SoftwarePropertiesDBus.py, tests/test_dbus.py:
    - fix crash when there are unicode comments in the sources.list
      file (LP: #820028). Dbus always sends us a dbus.String which is
      type unicode, but python-apt expects utf8 encoded str
 -- Michael Vogt <email address hidden> Mon, 10 Oct 2011 10:55:45 +0200

Changed in software-properties (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

included in oneiric, so will automatically make it into precise when it opens.

Changed in software-properties (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.